Go Back  DVD Talk Forum > DVD Discussions > DVD & Home Theater Gear
Reload this Page >

FYI: HDMI issue with Panasonic BD60 and Monoprice HDMI switch

DVD & Home Theater Gear Discuss DVD and Home Theater Equipment.

FYI: HDMI issue with Panasonic BD60 and Monoprice HDMI switch

Old 03-30-09, 06:35 AM
  #1  
DVD Talk Legend
Thread Starter
 
Join Date: Jun 1999
Location: USA
Posts: 12,201
FYI: HDMI issue with Panasonic BD60 and Monoprice HDMI switch

Well I thought I had a great plug and play solution setup for my theater.

I have been using the Monoprice HDMI 4 x 1 switch in my theater for over a year and had 3 devices connected to it.

I purchased the new Panasonic BD 60 (BD 605K @ Costco) and took it home to plug it into my switch and start watching BD.

Long story short (and about 2 hours) the player gets a U72 error which seems to be a known issue. The player has a problem with this type of hdmi connection and the only way I can use the player is to connect it directly to my projector. Unfortunately that means that I had to disconnect my Direct TV HD receiver and my PC from my projector.

I plan to buy a new receiver in the future but I wanted to pass this along to anyone in the same position.
Brian Shannon is offline  
Old 03-30-09, 09:54 AM
  #2  
DVD Talk Hero
 
Join Date: Dec 2000
Location: Home again, Big D
Posts: 27,799
Re: FYI: HDMI issue with Panasonic BD60 and Monoprice HDMI switch

Ewww...that does suck...

I'm also been using a Monoprice switcher for several years run to my projector. The monoprice evidently sometimes has issues with a PS3, but it has been flawless for me. I also have a Toshiba A-3 (I refuse to believe HD is dead...LMAO) and dishnetwork HD receiver.

And like you, I flirt with a new receiver now and again. But my H/K sounds so good I hate to kick it to the curb just because no HDMI. Tho, I'm considering giving it to my son if he goes to college, then I'd have to do something.....
Sdallnct is offline  
Old 03-30-09, 10:02 AM
  #3  
DVD Talk Legend
Thread Starter
 
Join Date: Jun 1999
Location: USA
Posts: 12,201
Re: FYI: HDMI issue with Panasonic BD60 and Monoprice HDMI switch

Well I knew the receiver switch was going to have to happen eventually, I hate to retire my Yamaha RX-V1 but the switch was only a stop gap solution.

I was not prepared however, for two hours of troubleshooting and finally realizing that the player would only work when plugged directly to my projector.

I may give it one last shot as I am waiting for either the BD80 or the Oppo BD83 as my final player for my theater. I only bought the 60 to have now, it will eventually go up into my family room and be connected to my Panasonic plasma. Perhaps the Oppo will not have the same problem with the switch which I could then put back and keep my receiver.
Brian Shannon is offline  
Old 03-30-09, 10:14 PM
  #4  
DVD Talk Limited Edition
 
Join Date: Mar 2002
Location: Mpls, MN
Posts: 6,831
Re: FYI: HDMI issue with Panasonic BD60 and Monoprice HDMI switch

You probably have a model from before they went fully 1.3 compliant. The rev 3.0 model should work.
Spiky is offline  
Old 03-31-09, 06:55 AM
  #5  
DVD Talk Legend
Thread Starter
 
Join Date: Jun 1999
Location: USA
Posts: 12,201
Re: FYI: HDMI issue with Panasonic BD60 and Monoprice HDMI switch

Originally Posted by Spiky View Post
You probably have a model from before they went fully 1.3 compliant. The rev 3.0 model should work.
That may be the case since the player is 1.3

I may have to try the new switch first as that would be a better move than an entire receiver at this point.

Thanks Spiky, don't know why I did not think of that earlier, just ordered a new one. If it doesn't work I'll just return it.

Damn really wanted that new Yamaha 3900 too!

Last edited by Brian Shannon; 03-31-09 at 07:08 AM.
Brian Shannon is offline  
Old 04-02-09, 04:12 PM
  #6  
DVD Talk Legend
Thread Starter
 
Join Date: Jun 1999
Location: USA
Posts: 12,201
Re: FYI: HDMI issue with Panasonic BD60 and Monoprice HDMI switch

Well the new HDMI 1.3a switch did not work either. Talking to Monoprice tech support got me a canned response that not all switches will work with all devices.

That was the end of the discussion.

I guess I am not blaming them but I am very disappointed.

I am not sure what I am going to do now.
Brian Shannon is offline  
Old 04-02-09, 09:07 PM
  #7  
DVD Talk Limited Edition
 
Join Date: Mar 2002
Location: Mpls, MN
Posts: 6,831
Re: FYI: HDMI issue with Panasonic BD60 and Monoprice HDMI switch

Well that sucks. The 35/55 have the same sensing, and my original 5x1 didn't work with my 55. But the 1.3 4x1 does work. Wouldn't be surprised if there is a firmware upgrade for the 60 that helps at some point.
Spiky is offline  
Old 04-03-09, 06:31 AM
  #8  
DVD Talk Legend
Thread Starter
 
Join Date: Jun 1999
Location: USA
Posts: 12,201
Re: FYI: HDMI issue with Panasonic BD60 and Monoprice HDMI switch

Originally Posted by Spiky View Post
Well that sucks. The 35/55 have the same sensing, and my original 5x1 didn't work with my 55. But the 1.3 4x1 does work. Wouldn't be surprised if there is a firmware upgrade for the 60 that helps at some point.

Possibly, but not yet, I checked.

I am becoming concerned that it may be the projector that is the problem. The Sharp XVZ10000U does not have an hdmi port, rather it is a dvi port that I use with an adapter.

My pc and my direct tv hd receiver all send output just fine to the projector. My Oppo 971 did as well. It is only the Panasonic BD player that has this U72error. I am not hesitant to try a new receiver, fearing that because the projector will still be connected with the dvi/hdmi adapters that it will still throw the code, even when switching through a receiver instead of a switch.

I am really at a loss
Brian Shannon is offline  
Old 04-03-09, 06:50 AM
  #9  
DVD Talk Legend
Thread Starter
 
Join Date: Jun 1999
Location: USA
Posts: 12,201
Re: FYI: HDMI issue with Panasonic BD60 and Monoprice HDMI switch

Well the plot gets worse.

It appears the by searching that this projector cannot work with hdmi 1.3 and that the adapter may be the problem.

BUT, the bd player works when being connected directly to the projector but not through the switch. All other devices work through the switch.

I guess I will take the player and the switch and try connecting them to my Panasonic plasma and see what happens. My plan was to put the Panasonic player with the plasma anyway and put the upcoming Oppo BD-83 in my theater, hence the reason I need to sort out where the problem is, the projector, the switch or the player. And whether or not a receiver to switch though would solve the problem.
Brian Shannon is offline  
Old 04-04-09, 04:03 PM
  #10  
DVD Talk Limited Edition
 
Join Date: Mar 2002
Location: Mpls, MN
Posts: 6,831
Re: FYI: HDMI issue with Panasonic BD60 and Monoprice HDMI switch

If the PJ works direct, it ought to work with a switch, don't you think? Meanwhile, it's the 1.3 devices that are touchiest. I would lean towards player at this point, but it's so new it's hard to say much.
Spiky is offline  
Old 04-06-09, 06:28 AM
  #11  
DVD Talk Legend
Thread Starter
 
Join Date: Jun 1999
Location: USA
Posts: 12,201
Re: FYI: HDMI issue with Panasonic BD60 and Monoprice HDMI switch

Originally Posted by Spiky View Post
If the PJ works direct, it ought to work with a switch, don't you think? Meanwhile, it's the 1.3 devices that are touchiest. I would lean towards player at this point, but it's so new it's hard to say much.
I agree, that is what makes this so strange. I may try swapping out the receiver anyway and see if the new Yamaha 3900 can do the switching. If so then I can get the new audio formats as well and add 7.1 speakers.
Brian Shannon is offline  
Old 04-07-09, 09:48 AM
  #12  
DVD Talk Limited Edition
 
Join Date: Jul 2003
Location: SnogBox
Posts: 7,192
Re: FYI: HDMI issue with Panasonic BD60 and Monoprice HDMI switch

Have you tried a different device on the back end of the switch instead of the projector? Do you have a small monitor or tv that you could move into that room to test?
Superman07 is offline  
Old 04-07-09, 12:27 PM
  #13  
DVD Talk Legend
Thread Starter
 
Join Date: Jun 1999
Location: USA
Posts: 12,201
Re: FYI: HDMI issue with Panasonic BD60 and Monoprice HDMI switch

Originally Posted by Superman07 View Post
Have you tried a different device on the back end of the switch instead of the projector? Do you have a small monitor or tv that you could move into that room to test?
I am going to test the switch with the same player and my Panasonic plasma, just have not had the time.

FWIW, that will only lead to two possible conclusions. One means that the switch is the problem and the other means that the projector is the problem.

Ultimately I would like to hang onto the projector for a while longer so the test of a new receiver with the player and my projector seems to be more valid.
Brian Shannon is offline  
Old 04-07-09, 04:40 PM
  #14  
Senior Member
 
Join Date: Feb 2000
Posts: 384
Re: FYI: HDMI issue with Panasonic BD60 and Monoprice HDMI switch

I have an philips 47 lcd. it has 4 hdmi ports. I also have the onkyo 605 and the HDMI switcher. I had problems with my panasonic 30 & the switcher. I used that on the onyko reciever.

Jacob
JACOB is offline  
Old 04-08-09, 06:06 PM
  #15  
DVD Talk Limited Edition
 
Join Date: Mar 2002
Location: Mpls, MN
Posts: 6,831
Re: FYI: HDMI issue with Panasonic BD60 and Monoprice HDMI switch

Another thing to try, Brian, is trying different inputs on the switcher. May seem ludicrous, but I've heard interesting things.
Spiky is offline  
Old 04-09-09, 06:28 AM
  #16  
DVD Talk Legend
Thread Starter
 
Join Date: Jun 1999
Location: USA
Posts: 12,201
Re: FYI: HDMI issue with Panasonic BD60 and Monoprice HDMI switch

Originally Posted by Spiky View Post
Another thing to try, Brian, is trying different inputs on the switcher. May seem ludicrous, but I've heard interesting things.
Agreed and thanks. Actually Monoprice also recommends this but it did not make a difference. I tried each input with and without other devices and got the same result.

And the situation gets weirder and more frustrating. I contacted Sharp customer service about the problem and was told emphatically that my projector does not support hdmi 1.3. I guess they skipped the part of my email that told them the player worked just fine when connected directly to the projector.

I am still trying to line up a 3900 to test
Brian Shannon is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread

Archive Advertising Cookie Policy Privacy Statement Terms of Service

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.