Release List Reviews Shop Join News DVD Giveaways Video Games Advertise
DVD Reviews | Theatrical Reviews | Price Search Buy Stuff Here
Video Game Talk
HD Reviews

Go Back   DVD Talk Forum > Entertainment Discussions > Video Game Talk

Video Game Talk The Place to talk about and trade Video & PC Games

Thread Tools
Old 03-04-02, 05:43 PM   #1
New Member
Join Date: Oct 2001
Posts: 5
Needs help for PS2 sound optimization

I have my PS2 connected to my Dennon Receiver using an optical cable. I have a separate DVD player that also uses an optical cable and I have no problems getting digital play back on my DVD player. But I noticed that my PS2 always uses Pro Logic 2 instead of using digital play back that my DVD player uses. At first, I thought it was because of the game, but when I decided to use a DVD in my PS2, the sound still used the Pro Logic 2.

My receiver has multiple optical cable inputs and I am using the input for VCR1. Should I be using VDP input (assuming VDP means video digital player).

My PS2 has been set for optical sound but I don't know why my receiver won't take it in digital format. My receiver is also set for receiving VCR1 for optical connections.

Any suggestions are greatly appreciated.

  Reply With Quote
Old 03-04-02, 06:32 PM   #2
Join Date: Mar 2001
Posts: 168
i don't have a PS2, but i can still say that i don't think its a problem with your reciever accepting a digital signal. if you are hearing the game then the signal is being sent correctly to the reciever. the problem you seem to be describing is that its just not playing in the sound format that you want.

i would look for these things:
1) my reciever has a "listening mode" button that switches between stereo, pro-logic, mono, etc. this mode is set differently for each input. for instance my vcr input is set to pro-logic and my game input is usually set to stereo. check for this on your reciever and see if that's the problem.

2) i'm not positive but doesn't the PS2 have a sound option? if so then check to see if this is set correctly.

again, if you are hearing the games then the reciever is getting the digital signal. you just have to find the right settings to get the sound you want.
  Reply With Quote
Old 03-04-02, 10:31 PM   #3
Cardiff Giant11
DVD Talk Limited Edition
Join Date: Apr 2000
Location: Earth
Posts: 5,865
I had this same problem. Three things to do
1)Turn on the optical output in the Setup menu of the PS2
2)Put in a DVD Movie and press select. Then highlight the setup menu. Turn on DD and DTS sound. This is for the DVD player only. Otherwise, you won't get digital sound from the ps2 dvd player
3) If your game supports DD or DTS, you have to turn it on in the sound menu of the game.
I had the exact same problem with mine when I first set it up and it took me about 45 minutes to figure it out.
PSN Name CardiffGiant11
  Reply With Quote
Old 03-04-02, 11:25 PM   #4
Senior Member
Join Date: Nov 2000
Location: Cincinnati, OH
Posts: 424
It is very rare to find a game that will support DD and if it does, it will only be in cut scenes. So other than DTS games like NHL, your games will be using Prologic (but still digital sound) in game play. It kind of sucks but nothing can be done yet. This is one reason I love the sound of my Xbox. Real time DD 5.1 but the PS2 still gets used the most cause of the great games. Hope this clarifies.
Creator of the new world which will be known only as........ "THE"

My DVD's
  Reply With Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 09:45 PM.

Rules - DVD Talk - Archive - Privacy Statement - Top

Copyright 2011 All Rights Reserved. Privacy Policy and Terms of Use.

Content Relevant URLs by vBSEO 3.2.0