Go Back  DVD Talk Forum > General Discussions > Tech Talk
Reload this Page >

WinVNC with Router - Help Needed!

Tech Talk Discuss PC Hardware, Software, Internet and Other Technology

WinVNC with Router - Help Needed!

Old 07-20-04, 07:18 AM
  #1  
DVD Talk Legend
Thread Starter
 
Join Date: Mar 2002
Location: Newfoundland, Canada
Posts: 14,020
Likes: 0
Received 0 Likes on 0 Posts
WinVNC with Router - Help Needed!

I am having a bit of a hard time getting WinVNC to work after installing my wireless router (SMC7004VWBR). I know that I have to enable port forwarding to get remote access, but I can't seem to figure out how to do it. I am pretty sure that it is under the NAT setting in the router advanced setup, I still can't get it to work. I am running XP Pro, but the issue seems to be the settings in my router config.

Can anyone point me to a site that might help, or post some useful info here? Many thanks...

Last edited by movieking; 07-20-04 at 07:24 AM.
Old 07-20-04, 08:43 AM
  #2  
DVD Talk Special Edition
 
Join Date: Aug 2001
Location: Arlington, VA
Posts: 1,806
Likes: 0
Received 0 Likes on 0 Posts
It looks like it uses port # 5900. I just read about RealVNC last week, but I believe I'll be installing it sometime in the near future for one of my small companies I support. Here is their main site FAQ: http://www.realvnc.com/faq.html. You probably already know about that site though.
It sounds like your able to login to your router. Are you just having troubles with finding exactly where to do port forwarding from? Because a lot of routers are different, try checking their online documentation to see if it will help. Good luck.
Old 07-20-04, 09:30 AM
  #3  
DVD Talk Legend
 
Join Date: Jul 2000
Location: chokin' you out in less than 30 seconds
Posts: 10,634
Likes: 0
Received 0 Likes on 0 Posts
just like this:




sorry for the big pic. well, not really.
Old 07-20-04, 09:31 AM
  #4  
DVD Talk Legend
 
Join Date: Jul 2000
Location: chokin' you out in less than 30 seconds
Posts: 10,634
Likes: 0
Received 0 Likes on 0 Posts
it's a good idea to run some sort of dynamic dns tool as well....so you don't have to know your ip all the time.

i use no-ip for this: http://www.no-ip.com/dyndns-howto.php

Last edited by crankyman; 07-20-04 at 12:38 PM.
Old 07-20-04, 11:34 AM
  #5  
DVD Talk Gold Edition
 
Join Date: Oct 1999
Location: Beaverton, OR, USA
Posts: 2,536
Likes: 0
Received 0 Likes on 0 Posts
I've been successfully using Remote Desktop to access my PC at home from work. It was a little tricky, since our trusty Internet Nazi blocks the port that Remote Desktop wants to use. I use Remote Desktop, because it handles the dual monitor setup on my home PC much better than TightVNC did. When you connect to a PC running dual monitors with Remote Desktop, it will make all your apps run on one monitor.
Remote Desktop wants to use port 3389 by default. It's easy to change on the controlling end, but you need this reg hack to change the listening port on the remote side.
Old 07-20-04, 12:39 PM
  #6  
DVD Talk Legend
 
matome's Avatar
 
Join Date: Oct 1999
Location: NY
Posts: 12,304
Likes: 0
Received 0 Likes on 0 Posts
Originally posted by crankyman
it's a good idea to run some sort of dynamic dns tool as well....so you don't have to know your ip all the time.

i use no-ip for this: http://www.no-ip.com/dyndns-howto.php
I use them too, since I can't get a static IP from my ISP. Great service
Old 07-20-04, 02:46 PM
  #7  
DVD Talk Legend
Thread Starter
 
Join Date: Mar 2002
Location: Newfoundland, Canada
Posts: 14,020
Likes: 0
Received 0 Likes on 0 Posts
Thanks for all the help guys, as it is working now. I don't have the no-ip set up yet, but I am hoping to get it installed in the next couple of days.

DVDTalk, and crankyman in particular, comes through again!
Old 07-20-04, 05:31 PM
  #8  
DVD Talk Platinum Edition
 
Join Date: Sep 2001
Location: Deep, foggy, buggy, steaming South!
Posts: 3,723
Likes: 0
Received 0 Likes on 0 Posts
he is good with computer stuff and he has a really large penis.
Old 07-20-04, 10:49 PM
  #9  
DVD Talk God
 
twikoff's Avatar
 
Join Date: Feb 2000
Location: Right Behind You!!!
Posts: 79,497
Likes: 0
Received 0 Likes on 0 Posts
Originally posted by goofee girl
he is good with computer stuff and he has a really large penis.
ha!
that will teach not to forget to log out!
Old 07-21-04, 07:47 AM
  #10  
DVD Talk Legend
 
Join Date: Jul 2000
Location: chokin' you out in less than 30 seconds
Posts: 10,634
Likes: 0
Received 0 Likes on 0 Posts
i borrowed her laptop....err...i mean....she wrote that!
Old 09-03-04, 08:27 PM
  #11  
DVD Talk Legend
Thread Starter
 
Join Date: Mar 2002
Location: Newfoundland, Canada
Posts: 14,020
Likes: 0
Received 0 Likes on 0 Posts
Another question regarding WinVNC:

When I am running WinVNC now, the router address is what shows up in the VNC taskbar, instead of my actual IP address. I recently installed (and then quickly uninstalled) ZoneAlarm, and I think that this is what caused the change. Can anyone tell me what I have to do in order to get my external IP address to show up again?

Thanks
Old 09-06-04, 08:21 PM
  #12  
DVD Talk Legend
Thread Starter
 
Join Date: Mar 2002
Location: Newfoundland, Canada
Posts: 14,020
Likes: 0
Received 0 Likes on 0 Posts
Bumpo!
Old 09-06-04, 08:46 PM
  #13  
JM
DVD Talk Special Edition
 
Join Date: Dec 1999
Posts: 1,156
Likes: 0
Received 0 Likes on 0 Posts
Originally posted by movieking
Another question regarding WinVNC:

When I am running WinVNC now, the router address is what shows up in the VNC taskbar, instead of my actual IP address. I recently installed (and then quickly uninstalled) ZoneAlarm, and I think that this is what caused the change. Can anyone tell me what I have to do in order to get my external IP address to show up again?

Thanks
If by "router address" you mean your PC's LAN address, that is completely normal. With port forwarding correctly configured, you will still be able to access your PC via the WAN/external address.

BTW, IMO [email protected] is the best WinVNC option for Win32. It includes a lot of features the "original" WinVNC does not. For example, [email protected] supports file transfers whereas the original WinVNC does not (last time I used it anyway).
Old 09-10-04, 01:13 AM
  #14  
DVD Talk Legend
 
Join Date: Jan 2000
Location: Region 1
Posts: 16,291
Likes: 0
Received 0 Likes on 0 Posts
Originally posted by Nosmo Rex
I've been successfully using Remote Desktop to access my PC at home from work. It was a little tricky, since our trusty Internet Nazi blocks the port that Remote Desktop wants to use. I use Remote Desktop, because it handles the dual monitor setup on my home PC much better than TightVNC did. When you connect to a PC running dual monitors with Remote Desktop, it will make all your apps run on one monitor.
Remote Desktop wants to use port 3389 by default. It's easy to change on the controlling end, but you need this reg hack to change the listening port on the remote side.
Thanks for the Microsoft article. Now I need to test which port I can use to connect from work.
Old 09-10-04, 12:40 PM
  #15  
JM
DVD Talk Special Edition
 
Join Date: Dec 1999
Posts: 1,156
Likes: 0
Received 0 Likes on 0 Posts
Originally posted by zuffy
Thanks for the Microsoft article. Now I need to test which port I can use to connect from work.
Port 80 (HTTP) is a safe bet provided you don't already run a web server from your PC. Otherwise, try 8080 (HTTP Proxy), 443 (HTTPS), 21 (FTP), or 110 (POP3). It is unlikely that all of these common ports will be blocked.
Old 09-10-04, 12:44 PM
  #16  
DVD Talk Gold Edition
 
Join Date: Oct 1999
Location: Beaverton, OR, USA
Posts: 2,536
Likes: 0
Received 0 Likes on 0 Posts
Yes - I'm using 443 successfully.
Old 09-10-04, 01:34 PM
  #17  
DVD Talk Legend
 
Join Date: Jan 2000
Location: Region 1
Posts: 16,291
Likes: 0
Received 0 Likes on 0 Posts
I'm gonna give 443 a shot since they pretty much blocked all ports at the firewall.

I can't ping my PC now. I think Verizon renewed my IP
Old 09-10-04, 01:55 PM
  #18  
JM
DVD Talk Special Edition
 
Join Date: Dec 1999
Posts: 1,156
Likes: 0
Received 0 Likes on 0 Posts
Originally posted by zuffy
I'm gonna give 443 a shot since they pretty much blocked all ports at the firewall.

I can't ping my PC now. I think Verizon renewed my IP
This is why you should use dynamic DNS such as No-IP.com as mentioned above.
Old 09-10-04, 01:57 PM
  #19  
DVD Talk Legend
 
Join Date: Jan 2000
Location: Region 1
Posts: 16,291
Likes: 0
Received 0 Likes on 0 Posts
I did use No-IP.com. Is the dynamic DNS free?
Old 09-10-04, 11:38 PM
  #20  
DVD Talk Legend
 
Join Date: Jan 2000
Location: Region 1
Posts: 16,291
Likes: 0
Received 0 Likes on 0 Posts
OK. I did some troubleshooting and found out the cause of my problem. The reason I can't ping or connect to my PC has nothing to do with my router. It was ZoneAlarm blocking everything. I have to set the Internet Zone Security to Medium instead of High to be able to access it.
Old 09-11-04, 03:51 PM
  #21  
JM
DVD Talk Special Edition
 
Join Date: Dec 1999
Posts: 1,156
Likes: 0
Received 0 Likes on 0 Posts
Originally posted by zuffy
I did use No-IP.com. Is the dynamic DNS free?
Yes. The basic service they offer is free and is more than adequate for most people.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread

Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.