DVD & Home Theater Gear Discuss DVD and Home Theater Equipment.

PHILLIPS Model 642 issue....

Old 03-03-07, 12:25 PM
  #1  
Senior Member
Thread Starter
 
Join Date: Jan 2004
Location: Simi Valley, CA
Posts: 570
PHILLIPS Model 642 issue....

I've had this player for about 6 months, used it somewhat but not greatly. I notice watching JOE DIRT it seemed to be skipping or dropping frames consistently in the same scenes, etc if I replayed. Did not notice this before on other DVDs and assumed it was a bad disc. Noticed the same issue on another new disc and became curious. Tried this second disc on my computer and NO dropped frames. Tried JOE DIRT and NO dropped frames. I've since replaced my player with a slightly higher end model and these discs play fine.

But its not region free or PAL converting player like the Phillips.

Anyone shed any light here? Is this a firmware problem or just a crappy player?
Carcosa is offline  
Old 03-03-07, 09:52 PM
  #2  
DVD Talk Limited Edition
 
Join Date: Mar 2002
Location: Mpls, MN
Posts: 6,831
I know this will sound too simple:

Did you wash the disc?
Spiky is offline  
Old 03-04-07, 10:44 AM
  #3  
DVD Talk Ultimate Edition
 
Join Date: Sep 2006
Location: Dallas, TX
Posts: 4,128
probably not firmware, I've got two of those I've had for 2 years and never had issues like that, and I've watched Joe Dirt on them successfully.
zombeaner is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread

Archive Advertising Cookie Policy Privacy Statement Terms of Service

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.