DVD & Home Theater Gear Discuss DVD and Home Theater Equipment.

Onkyo 767C Speaker connection issue

Old 02-03-05, 02:58 PM
  #1  
Member
Thread Starter
 
Join Date: Jul 2001
Posts: 144
Onkyo 767C Speaker connection issue

Hey everyone,

Forgive me if there is some discussion on a problem similar to this, I searched but did not find one. Not sure if anyone may know but I have had a problem with my receiver and wonder what your thoughts are

I have the onkyo 767c home theater system. Well in the past week the front-right speaker has completely stopped working. (keep in mind this thing is only a year and 9 days old). However, the speaker is not blown since I hooked it up to a different port (front left)

Just seems to be the actual port for the front-right speaker channel in back of the receiver.

Has any ever had a problem like this and if so, any idea what may of caused it?

Thanks very much for any info you can provide
zaroff1 is offline  
Old 02-03-05, 07:06 PM
  #2  
DVD Talk Legend
 
Join Date: Jun 1999
Location: USA
Posts: 12,249
Since you diagnosed the problem properly it sounds like the speaker terminal has had the cold solder joint fail. If you know how to solder you could fix it yourself otherwise it is likely a job for a qualified shop.
Brian Shannon is offline  
Old 02-03-05, 07:16 PM
  #3  
Member
Thread Starter
 
Join Date: Jul 2001
Posts: 144
Yeah, I am horrible at soldering. Thanks very much for your help.
zaroff1 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread

Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.