Go Back  DVD Talk Forum > General Discussions > Tech Talk
Reload this Page >

Windows 2000 DVD problem?

Tech Talk Discuss PC Hardware, Software, Internet and Other Technology

Windows 2000 DVD problem?

Old 12-16-00, 05:21 PM
  #1  
Member
Thread Starter
 
Join Date: Sep 1999
Posts: 196
Likes: 0
Received 0 Likes on 0 Posts
my DVD playback has been really screwy ever since i installed Windows 2000 Professional
i have a Creative DVD5240E-1, and everytime i play a DVD the video and audio stutters.

it happens on all the dvd software i have: WinDVD 2.3, PowerDVD 2.55, and ATI 7
if anyone has any clue what i did wrong, or something to fix it please tell me
Old 12-16-00, 05:33 PM
  #2  
X
Administrator
 
X's Avatar
 
Join Date: Oct 1987
Location: AA-
Posts: 10,763
Likes: 0
Received 4 Likes on 3 Posts
You need to make sure DMA is enabled for your DVD drive. I'm not sure where to do it because it doesn't show up as an option for the drive in the hardware manager as it does in Win 98. I do know that PowerDVD asked me if I wanted DMA enabled the first time I ran it after installation, and I set it on there. So there must be at least a registry entry for DMA. I haven't had time to dig into the registry yet.

Perhaps you can do some research on MS and other sites as to how to enable DMA in Win 2000. And if you find out, I wouldn't mind hearing how to do it. Maybe, if you have to, uninstall PowerDVD and reinstall it to get it to ask you. By the way, I used version 3.0.

[This message has been edited by X (edited December 16, 2000).]
Old 12-16-00, 06:28 PM
  #3  
Member
Thread Starter
 
Join Date: Sep 1999
Posts: 196
Likes: 0
Received 0 Likes on 0 Posts
Anyone with Windows 2000 know how to enable DMA?
Old 12-16-00, 08:46 PM
  #4  
DVD Talk Legend
 
Join Date: Jan 2000
Posts: 16,173
Likes: 0
Received 0 Likes on 0 Posts
But of course Win2k is my second home

It requires a registry edit, are you man enough?

Edit the key HKEY_LOCAL_MACHINE\System\ CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0000 key and add a new DWORD value called EnableUDMA66 with a value of 1.

then reboot

oh yeah, and make sure you are logged on as an admin.

[This message has been edited by 4KRG (edited December 16, 2000).]
Old 12-16-00, 09:52 PM
  #5  
Senior Member
 
Join Date: May 2000
Location: California
Posts: 315
Likes: 0
Received 0 Likes on 0 Posts
You don't really need to fiddle with your registry. You can enable DMA on the IDE channel that your drive is on.
Old 12-16-00, 10:04 PM
  #6  
Cool New Member
 
Join Date: Sep 2000
Location: BAY AREA, CALIFORNIA
Posts: 42
Likes: 0
Received 0 Likes on 0 Posts
yup, the prefered way, at least for me, to enable dma in win2k is to do it from system devices.

go under ide channel, and whatever the channel(primary or secondary) your dvdrom drive is on. enable it there.

but sometime this will not work if your bios already setting the dma or pio mode at boot up. what you need to do is to disable your bios from initializing your dvdrom drive.

however, if you are running on a via kt133 base motherboard, there isnt support for dma under win2000 yet. via beta driver 4.26 suppose to support dma under win2k.

Old 12-16-00, 10:13 PM
  #7  
DVD Talk Legend
 
Join Date: Jan 2000
Posts: 16,173
Likes: 0
Received 0 Likes on 0 Posts
quote:<HR>Originally posted by thai:
yup, the prefered way, at least for me,
<HR>



So you're not man enough
Old 12-17-00, 01:28 AM
  #8  
Member
Thread Starter
 
Join Date: Sep 1999
Posts: 196
Likes: 0
Received 0 Likes on 0 Posts
I enabled DMA on everything now, but it still runs jerky. What other things can be causing the problems?

Could it be Win2k's CPU system idle priority thread?
Old 12-17-00, 02:08 AM
  #9  
X
Administrator
 
X's Avatar
 
Join Date: Oct 1987
Location: AA-
Posts: 10,763
Likes: 0
Received 4 Likes on 3 Posts
quote:<HR>Originally posted by els84:
I enabled DMA on everything now, but it still runs jerky. What other things can be causing the problems?

Could it be Win2k's CPU system idle priority thread?
<HR>


What speed is your CPU? What else do you have running/loaded on your computer?
Old 12-17-00, 02:48 AM
  #10  
Senior Member
 
Join Date: May 2000
Location: California
Posts: 315
Likes: 0
Received 0 Likes on 0 Posts
Make sure you have the DVD-Rom on an IDE channel of it's own, or sharing one with another CDRom or what not (something that's not actively reading while your using the DVD-Rom). If you have your DVD-Rom and your primary hard drive on the same channel, it is most likely causing this problem.
Old 12-17-00, 03:55 AM
  #11  
Member
Thread Starter
 
Join Date: Sep 1999
Posts: 196
Likes: 0
Received 0 Likes on 0 Posts
Well, the jerkiness started when I upgraded to Windows 2000. I have a 800mhz Pentium III, so thats not the problem.

What is the problem!
Old 12-17-00, 04:35 AM
  #12  
Cool New Member
 
Join Date: Sep 2000
Location: BAY AREA, CALIFORNIA
Posts: 42
Likes: 0
Received 0 Likes on 0 Posts
are you sure if it is really enabled? double check by going into your hardware devices and see if dma is enabled for the ide channel that your dvdrom is connected to, or it is still under pio4 mode.
Old 12-17-00, 04:46 AM
  #13  
X
Administrator
 
X's Avatar
 
Join Date: Oct 1987
Location: AA-
Posts: 10,763
Likes: 0
Received 4 Likes on 3 Posts
els84 -

You have already got every suggestion you need for the time being and you should check each and every one out. So far you eliminated the CPU speed one, and possibly the DMA one (possibly, I'm not convinced yet). Why don't you check out all the other excellent suggestions, one by one, until you have either found the problem, or verified that the suggestions have already been implemented. It's futile for everyone to add something else until the basics are covered.

If you are not able, or are unwilling to do this, I would suggest hiring a consultant who can do it for you.
Old 12-19-00, 06:10 PM
  #14  
Member
Thread Starter
 
Join Date: Sep 1999
Posts: 196
Likes: 0
Received 0 Likes on 0 Posts
I've tried everything. One of my friends suggested that I just do a clean install of Windows 2000. Any other new ideas on the topic of fixing my DVD playback?
Old 12-19-00, 06:19 PM
  #15  
X
Administrator
 
X's Avatar
 
Join Date: Oct 1987
Location: AA-
Posts: 10,763
Likes: 0
Received 4 Likes on 3 Posts
Not from me. You possibly could install on another partition or drive so you could test a fresh install without messing up the existing one. And did you install service pack 1 yet? That might be worth a try.
Old 12-19-00, 06:43 PM
  #16  
DVD Talk Legend
 
Join Date: Jan 2000
Posts: 16,173
Likes: 0
Received 0 Likes on 0 Posts
make sure all your drivers are updated. Especially the video driver.
Old 12-26-00, 05:40 AM
  #17  
New Member
 
Join Date: Dec 2000
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
I have a similar problem. I dual boot win98 and win2k pro. I use the asustek windvd software that came with my geforce and it refuses to play dual layer dvds when im in win2k but it plays other dvds fine, when i boot into win98 all dvds play fine. I downloaded trial version of powerdvd and it can play some discs that the windvd cannot but not all the discs the same program can play in win98. I know for sure dma is enabled and I have dvdrom on seperate ide channel from hard drive and my aspi is current.. I really have no idea whats doing this.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread

Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.