Go Back  DVD Talk Forum > General Discussions > Tech Talk
Reload this Page >

Assistance Request: My system slows when copying files from 1 drive to another

Tech Talk Discuss PC Hardware, Software, Internet and Other Technology

Assistance Request: My system slows when copying files from 1 drive to another

Old 09-16-05, 07:32 AM
  #1  
Senior Member
Thread Starter
 
Join Date: Sep 2002
Location: Alexandria, Va/Milpitas, Ca
Posts: 858
Assistance Request: My system slows when copying files from 1 drive to another

How can I troubleshoot this?

I have 3 drives, and when I copy files from 1 drive to another(doesn't matter if it's any drive) the computer slows down and gets choppy. Even when I play mp3 files, with nothing else running. It's strange, new XP Home install, very clean, no spyware, defragged(main drive) other drives are used for files/storage.

Thanks!

It's an old Dell 4550, P4 2.66ghz, 512ram.

TIA!
Barney1234 is offline  
Old 09-16-05, 09:12 AM
  #2  
DVD Talk Special Edition
 
Join Date: Aug 2001
Location: Arlington, VA
Posts: 1,806
How big of files are you talking about? 5 Megs or a gig?
kneijst1 is offline  
Old 09-16-05, 10:44 AM
  #3  
Senior Member
Thread Starter
 
Join Date: Sep 2002
Location: Alexandria, Va/Milpitas, Ca
Posts: 858
well...

A gig, 2 gigs, around that much, but they are separate files.
ranging from 25mb to 50, totalling 1 or 2 gigs, it varies.
But it's usually something large, small files don't hinder the system.

Thanks!



Originally Posted by kneijst1
How big of files are you talking about? 5 Megs or a gig?
Barney1234 is offline  
Old 09-16-05, 01:22 PM
  #4  
DVD Talk Legend
 
Join Date: Jan 2000
Posts: 16,173
I can not remember what kind of hard drive a Dell 4550 has in it, but if it is PATA style like I think, that would explain the slow down during file copy. PATA controllers are driven by the processor. If you get a SATA drive, the problem will lessen. If you get a SCSI drive, the problem will almost disappear.

Does that machine have Hyperthreading? If it does, enable it, that will help.
4KRG is offline  
Old 09-16-05, 06:19 PM
  #5  
DVD Talk Gold Edition
 
Join Date: Feb 1999
Location: HB, CA
Posts: 2,601
Look in the device manager and make sure that the controllers are using DMA and not PIO.

Putting more than 1 device per IDE channel is sub-optimal, but it shouldn't be as bad as what you're experiencing.
belboz is offline  
Old 09-16-05, 06:48 PM
  #6  
X
Administrator
 
X's Avatar
 
Join Date: Oct 1987
Location: AA-
Posts: 10,704
Originally Posted by belboz
Look in the device manager and make sure that the controllers are using DMA and not PIO.
Absolutely!

I hope this new install is service packed. I believe SP1 helped with DMA.
X is offline  
Old 09-17-05, 11:02 AM
  #7  
Senior Member
Thread Starter
 
Join Date: Sep 2002
Location: Alexandria, Va/Milpitas, Ca
Posts: 858
Thanks people, I looked at the details on my drives, and yes, sure enough 1 drive is PIO only. I'll use this as a storage drive and eliminate it from my setup as soon as it is full. It's a WD 160Gig, who would have thought that this 160 gig drive is not DMA friendly. I have a smaller 30 7200rpm drive as the main C drive, which is older than this 160, and is does have DMA support.

Thanks people for your help!!!
Barney1234 is offline  
Old 09-17-05, 11:19 AM
  #8  
X
Administrator
 
X's Avatar
 
Join Date: Oct 1987
Location: AA-
Posts: 10,704
It's not your drive, it's your IDE channel. There isn't a 160GB drive that can't use DMA.

Did you service pack? Is the drive set to use DMA in the BIOS?
X is offline  
Old 09-17-05, 11:30 AM
  #9  
Senior Member
Thread Starter
 
Join Date: Sep 2002
Location: Alexandria, Va/Milpitas, Ca
Posts: 858
Howday,

Yeah, I researched some more and found an article addressing the lack thereof/not enable DMA on some Dell forum.

You are correct X, I had to go into the system bios and change the channels to Auto.

I'm now trying to figure out why the DMA options are not available anymore in the Device Manger.

Maybe I have to set them to something else in the bios, rather than auto.

Service pack, mmm, I have all the recent MS updates, is there a specifc one?
Barney1234 is offline  
Old 09-17-05, 11:45 AM
  #10  
X
Administrator
 
X's Avatar
 
Join Date: Oct 1987
Location: AA-
Posts: 10,704
When service packed (perhaps before) XP automatically sets DMA on (when the BIOS allows it) so you don't set it in the Device Manager.

You need to have the latest service pack which is SP2. If you don't have it on CD download it from Microsoft.
X is offline  
Old 09-17-05, 06:34 PM
  #11  
Senior Member
Thread Starter
 
Join Date: Sep 2002
Location: Alexandria, Va/Milpitas, Ca
Posts: 858
Well, I can't figure out why the DMA enable option(advanced tab) is no longer available, but the good thing is that my system no longer stutters!!!

Thanks people!

It was the Bios setting.
Barney1234 is offline  
Old 09-17-05, 07:20 PM
  #12  
X
Administrator
 
X's Avatar
 
Join Date: Oct 1987
Location: AA-
Posts: 10,704
Originally Posted by Barney1234
Well, I can't figure out why the DMA enable option(advanced tab) is no longer available...
Because XP automatically sets DMA on if it can so there's no need to provide that tab when it's on.
X is offline  
Old 09-17-05, 07:30 PM
  #13  
Senior Member
Thread Starter
 
Join Date: Sep 2002
Location: Alexandria, Va/Milpitas, Ca
Posts: 858
thanks

X, okay, that's what you meant in the prior post.
Thanks X and Belboz!



Originally Posted by X
Because XP automatically sets DMA on if it can so there's no need
to provide that tab when it's on.
Barney1234 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread

Archive Advertising Cookie Policy Privacy Statement Terms of Service

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.