Go Back  DVD Talk Forum > General Discussions > Tech Talk
Reload this Page >

Need help setting up my Linksys router

Tech Talk Discuss PC Hardware, Software, Internet and Other Technology

Need help setting up my Linksys router

Old 02-25-05, 02:41 PM
  #1  
DVD Talk Limited Edition
Thread Starter
 
namrfumot's Avatar
 
Join Date: May 2000
Posts: 6,409
Likes: 0
Received 0 Likes on 0 Posts
Need help setting up my Linksys router

Just got my wireless network up and running. There is a program I use (a p2p program) that the router wont allow to access my computer (so people can upload from my computer). So I have to go into the other room and change the routers settings....

I go into the router's settings and go to the "Forwarding" section. I enter the TCP port numbers and enable them, and I enter the UDP port numbers and enable them. (using the numbers from the computer on which I want to run the program)

The last thing it needs is the IP address. On the router's software only allows you to change the last few numbers: 152.163.101.XXX...but when I check the IP address on my computer it's totally different: 178.184.101.XXX.

Whats the deal? I tried to add just the last few numbers, but it doesnt work. Any ideas?

Last edited by namrufmot; 02-25-05 at 02:44 PM.
Old 02-25-05, 03:01 PM
  #2  
Senior Member
 
Join Date: Jun 1999
Location: Natick, MA
Posts: 814
Likes: 0
Received 0 Likes on 0 Posts
When you use a router for your computer you are, essentially, creating a new network called a subnet. Your computer will now have a new IP address (a LAN IP address), that specifies its location on your home network.

Usually, your router will be the first hardware piece on the home network and your computer will be the second...and so on and so on for every gadget you have on your network (wireless printers, other computers, pda's, etc, etc.)

If you run ipconfig from your cmd window, you should see an address for your computer that is similar to the router's network address (the one you see when you run the "router software"). Use the last set of bits seen there as the numbers to use when forwarding any ports. For example, you should see 152.163.101.202. Use 202.

Hope that helps.
Old 02-25-05, 03:02 PM
  #3  
Moderator
 
Groucho's Avatar
 
Join Date: Mar 2000
Location: Salt Lake City, Utah
Posts: 71,383
Received 116 Likes on 78 Posts
While you're in there, you should set up your PC to have a static IP address (if you haven't already). That way, if for some reason the router assigns it another address it doesn't bork all your port forwarding.
Old 02-25-05, 04:01 PM
  #4  
DVD Talk Limited Edition
Thread Starter
 
namrfumot's Avatar
 
Join Date: May 2000
Posts: 6,409
Likes: 0
Received 0 Likes on 0 Posts
Thanks Groucho...I did that and like you said it gave me a new IP similar to the one on the router..the missing numbers were 101. So I added that and it still doesn't work Do I have to reboot the router or should it take effect immediately?
Old 02-25-05, 04:14 PM
  #5  
DVD Talk Limited Edition
Thread Starter
 
namrfumot's Avatar
 
Join Date: May 2000
Posts: 6,409
Likes: 0
Received 0 Likes on 0 Posts
Here is a pic:
[img=http://img39.exs.cx/img39/6972/untitledhhkk8he.th.jpg]

Last edited by namrufmot; 02-25-05 at 04:17 PM.
Old 02-25-05, 05:09 PM
  #6  
JM
DVD Talk Special Edition
 
Join Date: Dec 1999
Posts: 1,156
Likes: 0
Received 0 Likes on 0 Posts
1) Make sure any software firewalls running on the .101 PC (e.g. Windows Firewall) are either disabled or also have those ports open.

2) You will want to set the PC to a static IP outside the DHCP range (in your case, any unused IP from 192.168.1.2 to 192.168.1.99 would work. In Windows, you do that in the Properties | TCP/IP Properties area for your network adapter as listed in Control Panel | Network Connections. If you do not do this, any port forwards you set up will break when the DHCP IP of your PC changes.

3) Do you happen to have DSL? If so, it is likely you are in a double NAT situation, which will significantly complicate getting port forwarding working. In that case, please post the brand and model of your DSL modem, and I will be able to better advise you.
Old 02-25-05, 05:39 PM
  #7  
DVD Talk Limited Edition
Thread Starter
 
namrfumot's Avatar
 
Join Date: May 2000
Posts: 6,409
Likes: 0
Received 0 Likes on 0 Posts
1) All firewalls are turned off.

2) Do I do this on the computer that the router is hooked up to or mine?
Going into the settings on my computer here is the window: Is that were I set the IP for my computer?

3) No i have a Comcast Cable modem.

Last edited by namrufmot; 02-25-05 at 05:52 PM.
Old 02-25-05, 05:55 PM
  #8  
JM
DVD Talk Special Edition
 
Join Date: Dec 1999
Posts: 1,156
Likes: 0
Received 0 Likes on 0 Posts
You do it on the PC to which you intend to forward ports (i.e. the PC that will be running the P2P app). Enter 192.168.1.1 for the DNS and Gateway. Leave the subnet mask at the default of 255.255.255.0.
Old 02-25-05, 07:54 PM
  #9  
DVD Talk Limited Edition
Thread Starter
 
namrfumot's Avatar
 
Join Date: May 2000
Posts: 6,409
Likes: 0
Received 0 Likes on 0 Posts
Here is the way I have MY computer set:


And the Way I have the computer with the router set:
http://img39.exs.cx/my.php?loc=img39...ledhhkk8he.jpg

When I do this I get NO internet connection at all! Never mind the program running right..

As I said all firealls are turned off.
Old 02-25-05, 08:52 PM
  #10  
HN
DVD Talk Hall of Fame
 
Join Date: Oct 1999
Location: Los Angeles, CA
Posts: 8,359
Likes: 0
Received 4 Likes on 3 Posts
In the IP address, change the "101" to just something like "3" (in both the computer setting and in the port forwarding, make'em match) and in the "Use the following DNS server address" on the computer, try something like 4.2.2.1 and 4.2.2.2

Also, just to make sure, those are the correct TCP and UDP port numbers?
Old 02-26-05, 02:40 AM
  #11  
JM
DVD Talk Special Edition
 
Join Date: Dec 1999
Posts: 1,156
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by namrufmot
Here is the way I have MY computer set:


When I do this I get NO internet connection at all!
Of course you don't. You didn't follow my instructions, and consequently you have no name resolution capability on that PC. As I wrote above, enter 192.168.1.1 for your DNS server.

I also advised you to choose a static IP that is outside the DHCP range, and you didn't do that either. Again, you need to set the static IP on your PC to an unused IP in the range from 192.168.1.2 to 192.168.1.99 (at this point all of those should be unused, so just pick one). You will need to change the port forwarding entry in your router to match this new IP.
Old 03-01-05, 02:57 PM
  #12  
DVD Talk Limited Edition
Thread Starter
 
namrfumot's Avatar
 
Join Date: May 2000
Posts: 6,409
Likes: 0
Received 0 Likes on 0 Posts
Im such a retard.. can't figure this out! Trying to follow the above instructions this is how I have the router set up:

I chose 192.168.1.5 to be my static IP. (and yes i triple checked the Port numbers)

And this is how I have MY computer set up:

I have the matching static IP, and I put the DNS server in.

What am I doing wrong now? One again I apologize for being a 'tard.

Last edited by namrufmot; 03-01-05 at 03:03 PM.
Old 03-01-05, 03:21 PM
  #13  
HN
DVD Talk Hall of Fame
 
Join Date: Oct 1999
Location: Los Angeles, CA
Posts: 8,359
Likes: 0
Received 4 Likes on 3 Posts
currently, you have "Default Gateway" as 192.168.1.5; change that to 192.168.1.1

*oh, never have to apologize for this kind of thing. it's nice to know there's a place to find answers without having to feel bad about it. unless you use your cd tray as a cup holder...then you're a 'tard.

Last edited by HN; 03-01-05 at 03:24 PM.
Old 03-01-05, 03:43 PM
  #14  
DVD Talk Limited Edition
Thread Starter
 
namrfumot's Avatar
 
Join Date: May 2000
Posts: 6,409
Likes: 0
Received 0 Likes on 0 Posts
Thanks....at least I am now able to surf the web with the setting above.

But Overnet still doesn't work I checked the port numbers again and everything. I have the XP firewall turned off on my computer too.

Any ideas before I totally give up?
Old 03-01-05, 04:24 PM
  #15  
HN
DVD Talk Hall of Fame
 
Join Date: Oct 1999
Location: Los Angeles, CA
Posts: 8,359
Likes: 0
Received 4 Likes on 3 Posts
Ok, let's do this to figure out if it's computer/router settings or the program itself that's causing the problem:

In the router settings, next to "Port Range Forward" there is DMZ. Select that and put in your IP address (the 192.168.1.5) . This will now forward all ports to that IP.*

When you run ONet, what does it say in the status bar of the program? "Open/On" , "Unclear", "firewalled", etc?

*do this just for testing. don't leave it this way as it leaves you wide opening for all kinds of reaming.
Old 03-01-05, 11:54 PM
  #16  
JM
DVD Talk Special Edition
 
Join Date: Dec 1999
Posts: 1,156
Likes: 0
Received 0 Likes on 0 Posts
Just to be clear, the 192.168.1.5 PC is the one on which you are trying to use Overnet, right? Is your setup cable from wall->cable modem->Linksys router->PC (with nothing else in between)? What is the brand and model of your cable modem?
Old 03-05-05, 10:10 AM
  #17  
DVD Talk Limited Edition
Thread Starter
 
namrfumot's Avatar
 
Join Date: May 2000
Posts: 6,409
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by HN
Ok, let's do this to figure out if it's computer/router settings or the program itself that's causing the problem:

In the router settings, next to "Port Range Forward" there is DMZ. Select that and put in your IP address (the 192.168.1.5) . This will now forward all ports to that IP.*

When you run ONet, what does it say in the status bar of the program? "Open/On" , "Unclear", "firewalled", etc?

*do this just for testing. don't leave it this way as it leaves you wide opening for all kinds of reaming.
Ok...I tried this and it still didn't work. So I updated to the latest version of Overnet and it worked

Last edited by namrufmot; 03-05-05 at 01:33 PM.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread

Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.