Go Back  DVD Talk Forum > General Discussions > Tech Talk
Reload this Page >

Error in Microsoft Office Document

Tech Talk Discuss PC Hardware, Software, Internet and Other Technology

Error in Microsoft Office Document

Old 11-13-04, 11:01 AM
  #1  
DVD Talk Limited Edition
Thread Starter
 
Preacher's Avatar
 
Join Date: Sep 2000
Location: outside Toronto, Canada
Posts: 6,917
Likes: 0
Received 0 Likes on 0 Posts
Error in Microsoft Office Document

We have been faced with this error for quite a time. My wife is a writer and had been working for 6 months. While writing some of the keyboard buttons become a foreign language and we end up with accents and symbols. The only way to remove them is to restart the computer. This on some nights causes her to have to shutdown and restart 4 or 5 times. Needless to say it is infuriating. And is getting riidculous.

Steps we have taken:
1 - Uninstalled and reinstalled Office
2 - Tried another program (ie AbiWord)
3 - We wiped the computer and reinstalled the OS (as much as you can do with one of these goofy disks) and added SP2 after.
4 - Downloaded a copy of Office wondering if our store bought one was the issue
5 - Ran repair more than a few times.
6 - Tried other fonts and formats
7 - Searched online with no success at finding the same error. But we all know the internet. Wrong search or parameter and you do not find an answer.

Nothing solved the issue. So we have come to the conclusion that in some of the saved data must reside the error. And every time we import the data, which is the only constant, the errors return.

Anyone with an idea on how to clean the data other than us retyping any and all our saved Office documents please step up. This is truly frustrating and makes no sense that we are aware of.

Thx.
Old 11-13-04, 11:22 AM
  #2  
DVD Talk Limited Edition
Thread Starter
 
Preacher's Avatar
 
Join Date: Sep 2000
Location: outside Toronto, Canada
Posts: 6,917
Likes: 0
Received 0 Likes on 0 Posts
8 - Bought her a Logitech keyboard a few months back. Did not solve the issue.
Old 11-13-04, 11:48 AM
  #3  
DVD Talk Hall of Fame
 
Join Date: Nov 1999
Location: Vermont
Posts: 9,775
Likes: 0
Received 0 Likes on 0 Posts
Re: Error in Microsoft Office Document

Originally posted by Preacher

Nothing solved the issue. So we have come to the conclusion that in some of the saved data must reside the error. And every time we import the data, which is the only constant, the errors return.

Anyone with an idea on how to clean the data other than us retyping any and all our saved Office documents please step up. This is truly frustrating and makes no sense that we are aware of.

Thx.

Agreed about your conclusion that the corruption is in the data. Here's what I'd do:

1) Import the first 1/2 of the data in one document and see if I get errors.
2) If yes, I'd delete it (after saving the new stuff separately) and import the first 1/4 of the data.
3) Errors? Yes? Save new stuff and grab the first 1/8. Etc. until you grab a small enough section that you're comfortable either dumping or grabbing with a Copy and then Edit...Paste Special...Unformatted Text, which should eliminate the corruption.

If the answer to question 1 is No, I'd grab the second half of the data. And so on. The point here is to find and avoid the corrupt portion of the data.

It would appear you'll have to do all of this once for each of your saved documents. I'd try a test run to see if it worked with one before proceeding with the rest. The other thing you might do is just select all the text in the document and past as unformatted text (Edit...Paste Special) and re-format it -- this would depend on which method you'd think would be faster.
Old 11-13-04, 12:02 PM
  #4  
DVD Talk Limited Edition
Thread Starter
 
Preacher's Avatar
 
Join Date: Sep 2000
Location: outside Toronto, Canada
Posts: 6,917
Likes: 0
Received 0 Likes on 0 Posts
It may be the best option and seems a sensible approach. Being a writer she is moving through the document as she goes, unless the error is in there than many of the docs are not used as often. No issues in Excel or other files that we have seen with consistancy, But the Catch 22 question is whether the error occurs because she is using that document so consistantly or whether the error is in her docs. Wish there was some automated format to check for repairs to a flaw.

Wondering about the paste as unformatted text suggestion. Maybe.

How is the hub issue going? Read it and could not think if a useful suggestion.
Old 11-13-04, 12:42 PM
  #5  
Stealth Moderator
 
namja's Avatar
 
Join Date: Oct 1999
Location: In Transit, HQ
Posts: 25,006
Received 2 Likes on 2 Posts
Does the keyboard turn into a foreign language keyboard, or do the text that is already on the document all turn into a foreign language? If it is the former, then:

The moment you get the "foreign language ... with accents and symbols", (1) hit the backspace key to revert the text back to English, then (2) tap the right alt key just once (the one just to the right of the space bar). See if that does anything.
Old 11-13-04, 01:30 PM
  #6  
DVD Talk Limited Edition
Thread Starter
 
Preacher's Avatar
 
Join Date: Sep 2000
Location: outside Toronto, Canada
Posts: 6,917
Likes: 0
Received 0 Likes on 0 Posts
Originally posted by namja
Does the keyboard turn into a foreign language keyboard, or do the text that is already on the document all turn into a foreign language? If it is the former, then:

The moment you get the "foreign language ... with accents and symbols", (1) hit the backspace key to revert the text back to English, then (2) tap the right alt key just once (the one just to the right of the space bar). See if that does anything.
If she is writing later we will be sure to try it. I doubt we missed it and it only happens to specific keys but if it works....


Last edited by Preacher; 11-13-04 at 02:28 PM.
Old 11-13-04, 01:44 PM
  #7  
Stealth Moderator
 
namja's Avatar
 
Join Date: Oct 1999
Location: In Transit, HQ
Posts: 25,006
Received 2 Likes on 2 Posts
Actually, open up Word and start typing. Then tap the right alt key. Then type again to see if you get "funny text".

For many of the foreign languages, the toggle to switch between English and the foreign language is the right alt key. It's also automatically switched if a certain (seemingly random) combination of letters are typed.
Old 11-13-04, 03:14 PM
  #8  
DVD Talk Gold Edition
 
Join Date: Jun 2000
Location: QC, CA
Posts: 2,718
Likes: 0
Received 0 Likes on 0 Posts
copy the entire text to notepad. then copy it back into a new word document.. it the document was messed up .. thi sshould fix it.


maybe there is a reset settings to default for word that you can try?
Old 11-13-04, 05:07 PM
  #9  
DVD Talk Hall of Fame
 
Join Date: Nov 1999
Location: Vermont
Posts: 9,775
Likes: 0
Received 0 Likes on 0 Posts
Originally posted by nomaan
copy the entire text to notepad. then copy it back into a new word document.. it the document was messed up .. thi sshould fix it.
If you like doing things in multiple steps that you can do in one.

When I recommended above to use the Edit...Paste Special...Unformatted Text option, it's the same thing but easier.
Old 11-13-04, 05:09 PM
  #10  
DVD Talk Hall of Fame
 
Join Date: Nov 1999
Location: Vermont
Posts: 9,775
Likes: 0
Received 0 Likes on 0 Posts
Originally posted by Preacher

How is the hub issue going? Read it and could not think if a useful suggestion.
Thanks. Still the same, but I just bought a new case fan, so I'm going to install that and play with the hub at the same time.
Old 11-17-04, 10:38 AM
  #11  
DVD Talk Limited Edition
Thread Starter
 
Preacher's Avatar
 
Join Date: Sep 2000
Location: outside Toronto, Canada
Posts: 6,917
Likes: 0
Received 0 Likes on 0 Posts
Okay. Here is the problem. It started doing this a few minutes ago.

- this is question mark
- this is forward slash

- this is quote mark
- this is apostrophe

The comma and the perod key are fine. But when striking shift and either key we get the quote mark and the apostrophe.

^ - this is the shift and the left bracket key. You get both symbols when you hit shift but neither when just striking the key.

- is the right bracket key
- is the shift and right bracket key.
/ and \ is the key on top of TAB. Both unshifted and shifted.
and are the key on top of Enter.

What the heck is going on. Question mark. All the rest of the keys appear fine. Woman has been sick and unable to try importing the text more than just a test case. Lets say it went oddly. We appear to be getting Frenched. $%#?#&.

Last edited by Preacher; 11-17-04 at 10:41 AM.
Old 11-17-04, 10:58 AM
  #12  
DVD Talk Gold Edition
 
Join Date: Jun 2000
Location: QC, CA
Posts: 2,718
Likes: 0
Received 0 Likes on 0 Posts
err ... do you have FR in the taskbar? if yes, click it, and change it to EN.

if not, go to control panel, regional and language options, languages. details --> set your defualt imput language to english.


Last edited by nomaan; 11-17-04 at 11:01 AM.
Old 11-18-04, 07:39 PM
  #13  
DVD Talk Limited Edition
Thread Starter
 
Preacher's Avatar
 
Join Date: Sep 2000
Location: outside Toronto, Canada
Posts: 6,917
Likes: 0
Received 0 Likes on 0 Posts
We have tried to change the default language to English - US instead of English - Canada. It was a good suggestion but there does not seem to be a problem there. Unless there is a registry error with Office that happened on the first install and was repeated after formatting. She will be writing tonite so we will see if it happens again.

Since the docs are hers I will post after she transfers them over. Thx.
Old 11-19-04, 02:43 AM
  #14  
Stealth Moderator
 
namja's Avatar
 
Join Date: Oct 1999
Location: In Transit, HQ
Posts: 25,006
Received 2 Likes on 2 Posts
That's not an error. If you have English (Canada) installed or if you have French (Canada) installed, then you will get that.

Hit the left alt and the left shift together, that converts the keyboard from English to French. Press the combination again, the keyboard reverts back to English. You can also change languages using nomaan's instructions if you have the language bar displayed.

I installed English (Canada) in my computer to test this, and I can duplicate this in my computer. When I press those keys you described, I get those French characters.
Old 11-19-04, 05:30 PM
  #15  
DVD Talk Limited Edition
Thread Starter
 
Preacher's Avatar
 
Join Date: Sep 2000
Location: outside Toronto, Canada
Posts: 6,917
Likes: 0
Received 0 Likes on 0 Posts
I replaced the other option as being Canada (French) instead of the US (English) that I had recently put in. And it did exactly that. It seems to be the answer.

We wasted an awful amount of time. She is at home trying it and we will see if when it occurs that is the reason why. When she was checking through some of the docs they had portions that were on the Canada (French) option. So while writing, copy/pasting and rewriting, the change of language would probably keep coming back from some previous enacting of those keystrokes.

Ya learn something new on computers all the time it appears. Thx for all the suggestions and to namja. If this works for good I no longer have to hear her curse and shutdown and restart all the time. And she says thx also.
Old 11-19-04, 08:28 PM
  #16  
Stealth Moderator
 
namja's Avatar
 
Join Date: Oct 1999
Location: In Transit, HQ
Posts: 25,006
Received 2 Likes on 2 Posts
Well ... if you never use French, then you can set the language option to English (United States) and remove all the other languages. Then you shouldn't get into French or any other language problems.
Old 11-20-04, 11:52 AM
  #17  
DVD Talk Limited Edition
Thread Starter
 
Preacher's Avatar
 
Join Date: Sep 2000
Location: outside Toronto, Canada
Posts: 6,917
Likes: 0
Received 0 Likes on 0 Posts
Nope has not completely fixed it. But I already had it set to the US as the other option, did that a few days ago. When I set it back it did the other thing that it does. I will leave it up to her to explain here. BUT removing the Canada (French) option seems to have removed both issues.

It seems apparent that having the French option causes the other issue to occur. And when you go into Regional options and remove the French option they both go away.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread

Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.