Go Back  DVD Talk Forum > General Discussions > Tech Talk
Reload this Page >

New NVidia drivers not working with my GeForce 2/MX400

Tech Talk Discuss PC Hardware, Software, Internet and Other Technology

New NVidia drivers not working with my GeForce 2/MX400

Old 07-22-04, 03:38 PM
  #1  
DVD Talk Special Edition
Thread Starter
 
Join Date: Feb 2002
Posts: 1,371
Likes: 0
Received 0 Likes on 0 Posts
New NVidia drivers not working with my GeForce 2/MX400

NVidia just released new drivers for thier video cards (driver version 61.76 Win9X). I downloaded the for my GeForce 2/MX400 64mb card, installed them and they crashed my machine. I tried to reboot and I got "Windows Protection Error. Startup Halted. Restart Your Computer Now.". But Ctrl+Alt+Del didn't work so I had to press reset. I did a system restore in Safe Mode and now I'm running on the old drivers (I'm running Windows ME by the way on an 800mhz AMD Athlon, 256mb SDRAM system).

This happened twice. I've even uninstalled the older drivers but I still get the same results. Has anyone else been having problems with the new NVidia drivers?
Old 07-22-04, 04:28 PM
  #2  
DVD Talk Legend
 
AGuyNamedMike's Avatar
 
Join Date: Jul 2000
Location: (formerly known as Inglenook Hampendick) Fairbanks, Alaska!
Posts: 15,275
Likes: 0
Received 0 Likes on 0 Posts
Win ME?

I have had all kinds of drivers do similar stuff. Stick with your old drivers until an even newer one is released. Have you considered upgrading your OS? Your machine would run XP just fine if you turned off the pretty stuff and set it to Classic Mode. My most used home machine is a P3-600 with 384MB RAM and XP Pro. You would get all sorts of new functionality and the new drivers probably wouldn't cause as many problems. For now, though, just stick with the older drivers.
Old 07-23-04, 02:59 PM
  #3  
DVD Talk Special Edition
Thread Starter
 
Join Date: Feb 2002
Posts: 1,371
Likes: 0
Received 0 Likes on 0 Posts
I have considered upgrading the OS. However I'm planning to purchase a new computer once I get my hands on some extra cash.

For now I'm trying to squeeze as much as I can out of this machine.
Old 07-23-04, 10:35 PM
  #4  
DVD Talk Special Edition
 
Join Date: Sep 1999
Location: Great White North. Take Off Eh! You hosers ....
Posts: 1,455
Likes: 0
Received 0 Likes on 0 Posts
I'm running the newest drivers for my amd k6-3 450, 384mb, Riva TNT 16mb XP Pro! and it's doing alright ... noticed a few hiccups but we'll see how it goes otherwise i'll have to roll it back possibly.

You can certainly get more out of your comp if you have an 800mhz Athlon ... but I don't play games on mine (at least at not more than 2fps anyways) so i'm not too worried. Time to upgrade though.
Old 07-24-04, 12:10 PM
  #5  
DVD Talk God
 
Deftones's Avatar
 
Join Date: Oct 1999
Location: Arizona
Posts: 74,983
Likes: 0
Received 4 Likes on 3 Posts
My brother has had trouble with that exact same card. Every time he starts up a game, it freezes and then crashes.
Old 07-24-04, 02:21 PM
  #6  
DVD Talk Legend
 
Join Date: Jun 1999
Location: USA
Posts: 12,272
Received 0 Likes on 0 Posts
Been there before.

You must use the drivers for Win ME, not the latest drivers for the card or the latest drivers period. As a matter of fact the last time I tried this and got later versions of drivers to work, the performance was worse.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread

Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.