Go Back  DVD Talk Forum > General Discussions > Tech Talk
Reload this Page >

Need help configuring router for Remote Desktop.

Tech Talk Discuss PC Hardware, Software, Internet and Other Technology

Need help configuring router for Remote Desktop.

Old 06-02-04, 07:56 AM
  #1  
DVD Talk Special Edition
Thread Starter
 
Join Date: Dec 2000
Posts: 1,778
Need help configuring router for Remote Desktop.

Iíve got 2 XP Pro laptops connecting to a Linksys Wireless router (WRT55AG), which is connected to a DSL modem. I used the instructions found here to set up Remote Desktop, but I still canít seem to connect remotely. I know Iím just not doing something right with the router config. I am probably not doing the port forwarding thing correctly. Can anyone help?
Patrick G is offline  
Old 06-02-04, 08:25 AM
  #2  
DVD Talk Special Edition
Thread Starter
 
Join Date: Dec 2000
Posts: 1,778
By the way, here is a screenshot of the port forwarding page in my router config. Letís say I want to connect on port 999 from outside my LAN. How would I configure it, and are there additional configs I need to make in the router?

Patrick G is offline  
Old 06-02-04, 08:32 AM
  #3  
DVD Talk Special Edition
Thread Starter
 
Join Date: Dec 2000
Posts: 1,778
I guess I also need to forward port 3389 per the instructions in that link.
Patrick G is offline  
Old 06-02-04, 10:14 AM
  #4  
DVD Talk Gold Edition
 
Join Date: Feb 2000
Location: Greenville, NC
Posts: 2,462
Yes. 3389 is the default port that Remote Desktop uses. Under "Customized Applications" you could type Remote Desktop, under External Port just enter 3389 for both, check both TCP and UDP (not sure if both are needed but I always check both, and then in the IP Address box enter the IP of the computer you wish to be able to connect to.

One problem I've had is that the computers attached to the router normally use DHCP for their IP addresses, which means that at one time the computer I connect to remotely could be IP 192.168.1.100 and once the computer is rebooted it could possibly be another IP, thus breaking the nice little forwarding I have going on. To combat that I usually give my internal computers static IP's to make sure they do not change.

I forgot the most important step and that is to find the external IP address that your router has and then try to connect to that IP remotely. It should be listed on the first page of the setup screen that you posted a screenshot of.

I apologize if this is too basic.
mtucker is offline  
Old 06-02-04, 10:32 AM
  #5  
DVD Talk Special Edition
Thread Starter
 
Join Date: Dec 2000
Posts: 1,778
Do I HAVE to have a name under Customized Applications?
Patrick G is offline  
Old 06-02-04, 10:35 AM
  #6  
DVD Talk Gold Edition
 
Join Date: Feb 2000
Location: Greenville, NC
Posts: 2,462
Probably not, I'm not sure. I think it is just a way to describe what application that particular port forwarding is for. A few of mine are "BitTorrent", "DirectConnect", and a few others.
mtucker is offline  
Old 06-02-04, 11:04 AM
  #7  
DVD Talk Legend
 
Shazam's Avatar
 
Join Date: Jul 1999
Location: Canuckistan
Posts: 10,027
No, you don't need to have a name under Customized Applications.

Note that you don't need UDP for Remote Desktop, and I recommend that you don't enable it.
Shazam is offline  
Old 06-02-04, 01:19 PM
  #8  
DVD Talk Special Edition
Thread Starter
 
Join Date: Dec 2000
Posts: 1,778
This is what I have for my DHCP page:

Patrick G is offline  
Old 06-02-04, 02:44 PM
  #9  
JM
DVD Talk Special Edition
 
Join Date: Dec 1999
Posts: 1,156
Originally posted by Patrick G
This is what I have for my DHCP page:
Why do you have 192.168.1.101 set as DNS1? Do you have a DNS server running at that address?

If not, I think you may be a little confused. That is not how you assign a static IP to your PC. Put DNS1 back at 0.0.0.0. To assign a static IP to your PC, go to the Control Panel | Network Connections. Right-click your LAN connection, choose "Properties," select "Internet Protocol (TCP/IP)," and click "Properties." Select "Use the following..." and enter the following:

IP: Any UNUSED address from 192.168.1.2 to 192.168.1.99 (i.e. outside the DHCP range but within the same subnet)

[EDIT - Nevermind. (I had been confused as to why your router seemed to be set for 192.168.3.x in the first screenshot but 192.168.1.x in the second, but I figured out the first is just a screenshot from the web, not from your actual config.) The below info should work for you]

Subnet mask: 255.255.255.0

Default gateway: 192.168.1.1

Preferred DNS server: 192.168.1.1

Alternate DNS server: 192.168.1.1

Take the IP address you chose above and create a port forwarding entry in your router's config pages. I.e. forward external TCP port 3389 to internal port 3389 for the IP you specified above.

Last edited by JM; 06-02-04 at 03:00 PM.
JM is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread

Archive Advertising Cookie Policy Privacy Statement Terms of Service

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.