Go Back  DVD Talk Forum > General Discussions > Tech Talk
Reload this Page >

HELP!! Can't delete .avi files

Tech Talk Discuss PC Hardware, Software, Internet and Other Technology

HELP!! Can't delete .avi files

Old 01-03-04, 11:36 PM
  #1  
Member
Thread Starter
 
Join Date: Oct 1999
Location: Ohio, USA
Posts: 128
Likes: 0
Received 0 Likes on 0 Posts
HELP!! Can't delete .avi files

I'm running a Compaq/Pentium 4/1.7 GHz/XP Home/SP 1 PC. I downloaded a few AVI files and now I can't delete them. When I go to delete one of them it says, "Error Deleteing File or Folder: It's being used by another person or program. Close any programs that might be using the file and try again."
I've tried a Norton wipe, delete in safe mode, reboot, and checking the Windows Task Manager with no luck. I like the Mad TV Alias Spoof, but not enough to keep it on my hard drive for all eternity. Please help. Thanks
Old 01-03-04, 11:38 PM
  #2  
X
Administrator
 
X's Avatar
 
Join Date: Oct 1987
Location: AA-
Posts: 10,765
Likes: 0
Received 4 Likes on 3 Posts
Sounds like a glitch.
Old 01-03-04, 11:40 PM
  #3  
Member
Thread Starter
 
Join Date: Oct 1999
Location: Ohio, USA
Posts: 128
Likes: 0
Received 0 Likes on 0 Posts
.......yes. I got my name for a reason. I seem to find the glitches, I just never know what to do with them.
Old 01-03-04, 11:43 PM
  #4  
X
Administrator
 
X's Avatar
 
Join Date: Oct 1987
Location: AA-
Posts: 10,765
Likes: 0
Received 4 Likes on 3 Posts
It also sounds like you have some kind of app running that has them ready to play or something.

Have you checked to see what's running in the background and whether something there might be keeping them open for quick access?
Old 01-04-04, 12:05 AM
  #5  
DVD Talk Hall of Fame
 
Join Date: Apr 2001
Location: Eugene, OR
Posts: 8,242
Likes: 0
Received 0 Likes on 0 Posts
Try to see if you can delete from the command prompt.
Old 01-04-04, 01:34 AM
  #6  
DVD Talk Hero
 
Join Date: Aug 2000
Location: Bartertown due to it having a better economy than where I really live, Buffalo NY
Posts: 29,706
Likes: 0
Received 0 Likes on 0 Posts
command prompt is all I can think of trying since you already did safe mode
maybe run scandisk too incase there's some sort of file system/cluster problem
Old 01-04-04, 02:00 AM
  #7  
Member
 
Join Date: Jun 2003
Posts: 116
Likes: 0
Received 0 Likes on 0 Posts
This is a bug with the way XP handles video files. It attempts to load any AVI files in order to show them in the preview pane, regardless of whether you actually have the pane shown. This is a fix from the registry edit file I run whenever I install XP:

[-HKEY_CLASSES_ROOT\SystemFileAssociations\.avi\shellex\PropertyHandler]

You can toss that in a file called XXX.reg or just navigate to the folder through regedit and delete it. I can't remember if it affects anything besides the previewing, but I haven't noticed any problems since I started doing it. You can run a search on Google if you want to make sure it works.
Old 01-04-04, 03:19 AM
  #8  
DVD Talk Limited Edition
 
Join Date: Jun 2001
Location: Under a dead Ohio sky
Posts: 5,820
Likes: 0
Received 0 Likes on 0 Posts
If the registry hack doesn't work just rename the file to stupid.file or some other random name with an extension that windows wont recognize. Then reboot and delete it. If that doesn't work empty the folder its in (except for the file in question of course) and delete the folder.
Old 01-04-04, 06:13 AM
  #9  
Member
Thread Starter
 
Join Date: Oct 1999
Location: Ohio, USA
Posts: 128
Likes: 0
Received 0 Likes on 0 Posts
I tried Thrush's suggestion with the "stupid.file" and the deleting the entire folder and got the same message that I can't do anything because it's being used.
Unfortunately I've never used the command prompt or the registry edit so I wouldn't know where to begin. All I see are jumbled numbers and letters in the registry and I don't know what to do when I open the command prompt. ........feeling a little lost here.......I felt like a god when I figured out Photoshop. This other stuff is outa my league. I'm just left in awe of the internal goings on of my computer.
Old 01-04-04, 07:31 AM
  #10  
Member
Thread Starter
 
Join Date: Oct 1999
Location: Ohio, USA
Posts: 128
Likes: 0
Received 0 Likes on 0 Posts
I ended up burning the midnight oil on this one and found a solution that worked!!!!
In case any other poor soul like myself has this happen.....who are we trying to kid? It's Micro$oft. Of course it will happen to someone else...... here's what you do (thanks to a German fellow named Raymond):

Goto Start ==>Run type "regedit", enter Now you're in the register Delete this registerkey: HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{87D62D94-71B3-4b9a-9489-5FE6850DC73E}\InProcServer32. DON'T CHANGE ANYTHING ELSE!!! Close register and restart pc. The problem with the avi's should be disappeard.

You can see the whole discussion here:
Annoyances.org

It really worked. I can't believe it! Now that it's 7:30 AM, I can finally get some sleep. Thanks.
Old 01-05-04, 04:03 AM
  #11  
DVD Talk Limited Edition
 
Join Date: Sep 2000
Posts: 6,341
Likes: 0
Received 0 Likes on 0 Posts
thanks. believe it or not, i've always had this problem too, but for me the undeletable files tend to be able to be deleted sometime later. don't know why though. i'll try that method and see if it works.
Old 01-05-04, 04:16 AM
  #12  
Suspended
 
Join Date: Mar 2003
Location: 5 Point West Side
Posts: 2,171
Likes: 0
Received 0 Likes on 0 Posts
eh, all I had to do was restart the system. If I want faster results, open properties for the file and ok it. Done. I'm not touching the registry thank you very much.
Old 01-05-04, 05:20 AM
  #13  
DVD Talk Special Edition
 
Join Date: Sep 1999
Location: Great White North. Take Off Eh! You hosers ....
Posts: 1,455
Likes: 0
Received 0 Likes on 0 Posts
This is a common problem actually. I had this problem awhile back with an .avi file that would not "delete".

Actually, the file data has been removed already but the file heading won't "leave" your comp unless you go into command line and remove it there.

Nav your way like DOS and remove the file with the usual commands and it's gone.

In the beginning one auto thinks that it's some sort of Trojan or something like that. I thought it was because it was a file downloaded from Kazaa and i'm thinking "this is karma working"
luckily it wasn't and I was able to get satisfaction.
Old 01-05-04, 07:07 AM
  #14  
Senior Member
 
Join Date: Apr 2000
Location: East Coast
Posts: 298
Likes: 0
Received 0 Likes on 0 Posts
I've encountered this problem myself. The best way to deal with it is to right click on it, wait about a min or wait for your hard drive to stop clicking away (whichever comes first), then press delete. This allows Windows to "pre-load" it before attempting to delete it.
Old 01-05-04, 08:27 AM
  #15  
DVD Talk Ultimate Edition
 
Join Date: Jun 2000
Posts: 4,771
Likes: 0
Received 0 Likes on 0 Posts
The easiest solution I've used is to open Notepad. Then click File Open... Make sure File Types is All. Go to where the avi is saved. Select it. And click the delete key, instead of trying to open it. Works every time for me.
Old 01-05-04, 11:48 PM
  #16  
DVD Talk Special Edition
 
Join Date: Sep 1999
Location: Great White North. Take Off Eh! You hosers ....
Posts: 1,455
Likes: 0
Received 0 Likes on 0 Posts
Originally posted by Palaver
The easiest solution I've used is to open Notepad. Then click File Open... Make sure File Types is All. Go to where the avi is saved. Select it. And click the delete key, instead of trying to open it. Works every time for me.
This sounds too easy!
Old 01-06-04, 10:09 AM
  #17  
DVD Talk Special Edition
 
Join Date: Jun 1999
Location: L.A., CA
Posts: 1,102
Likes: 0
Received 0 Likes on 0 Posts
i've had this problem before. had a 90mb avi that wouldn't delete so i cleared out the contents of that folder that it was in, and zipped the folder. then i was able to delete it.
Old 01-08-04, 01:56 PM
  #18  
Senior Member
 
Join Date: Feb 2003
Posts: 744
Likes: 0
Received 0 Likes on 0 Posts
Originally posted by Palaver
The easiest solution I've used is to open Notepad. Then click File Open... Make sure File Types is All. Go to where the avi is saved. Select it. And click the delete key, instead of trying to open it. Works every time for me.
i recently had this problem and that solution worked like a charm. too easy!
Old 01-09-04, 10:26 AM
  #19  
DVD Talk Hall of Fame
 
Join Date: Jan 2000
Location: Chicago, IL
Posts: 9,334
Likes: 0
Received 0 Likes on 0 Posts
eh, all I had to do was restart the system. If I want faster results, open properties for the file and ok it. Done. I'm not touching the registry thank you very much.
Fixing the registry is actually a very simple operation, much more than the piecemeal suggestions suggested.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread

Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.