Go Back  DVD Talk Forum > General Discussions > Tech Talk
Reload this Page >

How to make TMPGEnc hog the CPU?

Tech Talk Discuss PC Hardware, Software, Internet and Other Technology

How to make TMPGEnc hog the CPU?

Old 12-31-03, 11:30 PM
  #1  
DVD Talk Hero
Thread Starter
 
Join Date: Apr 1999
Location: Duluth, GA, USA
Posts: 37,782
Likes: 0
Received 0 Likes on 0 Posts
How to make TMPGEnc hog the CPU?

On my new PC setup, I am running TMPGEnc to do some DVD encoding, and the highest CPU utilization rate I get is 50%. This is on a PC running XP (P4 2.6c, 1GB RAM, Abit IC7-MAX3, and plenty of disk space - 300GB+). I've also closed down extraneous programs, etc. It's running pretty lean, but that doesn't seem to matter since it's got CPU cycles to spare running at only 50%.

On the TMPGEnc side (options -> Environmental setting), I have all the CPU boxes checked except for the Multi-processor option, and I've tried checking the box with no change in CPU utilization. For the Task Priority, I have the High priority selected for active/non-active window.

On my older PC (Celeron II 1GHz, 512MB RAM, Asus CUSL-2 MB, 100GB of disk space free) running Windows 2000, when I run TMPGEnc, it'll hog the CPU something fierce (though running at full speed, its encoding speed is at least 3 times slower than the new PC).

Last edited by Patman; 01-01-04 at 12:19 AM.
Old 12-31-03, 11:37 PM
  #2  
DVD Talk Ultimate Edition
 
Join Date: Jun 2000
Posts: 4,030
Likes: 0
Received 0 Likes on 0 Posts
I think you can give the three finger salute(ctrl-alt-delete) and when the window with processes comes up you could right click on tmpg and move its priority up.
Old 01-01-04, 12:14 AM
  #3  
DVD Talk Hero
Thread Starter
 
Join Date: Apr 1999
Location: Duluth, GA, USA
Posts: 37,782
Likes: 0
Received 0 Likes on 0 Posts
In the task manager it's set to high already. Should I set it to "realtime"?
Old 01-01-04, 08:22 AM
  #4  
DVD Talk Ultimate Edition
 
Join Date: Jun 2000
Posts: 4,030
Likes: 0
Received 0 Likes on 0 Posts
Originally posted by Patman
In the task manager it's set to high already. Should I set it to "realtime"?

I've never done this, but it I don't think it would hurt to try. Are you trying to decrease the amount of time it takes to render a piece of video?
Old 01-01-04, 09:41 AM
  #5  
DVD Talk Hall of Fame
 
Music's Avatar
 
Join Date: Jan 2001
Location: Manch Vegas, NH
Posts: 8,222
Received 0 Likes on 0 Posts
Are you running the latest version of it?

Also (I'm not at my main PC or I would check) see if there is an option for hyper-threaded CPUS... because what you are seeing is a normal program (not written to take advantage of hyperthreading) using up all the processor it sees.

Last edited by Music; 01-01-04 at 11:32 AM.
Old 01-01-04, 10:08 AM
  #6  
DVD Talk Hall of Fame
 
Join Date: Oct 1999
Location: not CT
Posts: 9,618
Likes: 0
Received 0 Likes on 0 Posts
Is it possible that you are now limited by HD speed or something? So that you can now only encode as fast as you can read and rewrite?
Old 01-01-04, 12:35 PM
  #7  
DVD Talk Hero
Thread Starter
 
Join Date: Apr 1999
Location: Duluth, GA, USA
Posts: 37,782
Likes: 0
Received 0 Likes on 0 Posts
Well, I did check the "multi-processor" box and the 4 associated boxes below it, and it did hog the CPU cycles, but I couldn't discern any processing benefit in terms of time reduction for crunching through a 2 hour AVI, so I opted to uncheck the "multi-processor" box and just let it run as before.

I think I'm using version 2.53.25.
Old 01-02-04, 12:38 PM
  #8  
DVD Talk Special Edition
 
Join Date: Jan 2001
Location: New York, N.Y.
Posts: 1,713
Likes: 0
Received 0 Likes on 0 Posts
on a related note, i've noticed that cpu usage does not match the bar graph. When I run tempgenc, i get 50% usage, but the graph shows the cpu usage at its peak. which is correct? (I am using a P4 3.0 Ghz on windows XP pro).
Old 01-02-04, 02:07 PM
  #9  
DVD Talk Hall of Fame
 
Blake's Avatar
 
Join Date: Feb 1999
Location: Orange
Posts: 7,737
Likes: 0
Received 0 Likes on 0 Posts
If you're using a Hyperthreading processor, TMPGEnc is probably using it all, but it's being reported to windows that the processor is only at 50% because of the "hyperthreading" aspect. I own a dual P4 with hyperthreading, and I turned it off because it actually causes a performance hit unless your applications are set up to fully utilize multiple processors (or at least I was told this is the best way to run a dedicated web server).

I would think it's actually at 100%, but is being reported at 50% for some strange reason - especially if you have the Priority set to high.
Old 01-02-04, 03:10 PM
  #10  
DVD Talk Hero
Thread Starter
 
Join Date: Apr 1999
Location: Duluth, GA, USA
Posts: 37,782
Likes: 0
Received 0 Likes on 0 Posts
I'm going to give version 2.59 a try (it's the first version that supports hyperthreading) and report back whether or not the encode time improved or not.
Old 01-02-04, 05:07 PM
  #11  
DVD Talk Special Edition
 
Join Date: Jan 2001
Location: New York, N.Y.
Posts: 1,713
Likes: 0
Received 0 Likes on 0 Posts
Originally posted by Blake
If you're using a Hyperthreading processor, TMPGEnc is probably using it all, but it's being reported to windows that the processor is only at 50% because of the "hyperthreading" aspect. I own a dual P4 with hyperthreading, and I turned it off because it actually causes a performance hit unless your applications are set up to fully utilize multiple processors (or at least I was told this is the best way to run a dedicated web server).

I would think it's actually at 100%, but is being reported at 50% for some strange reason - especially if you have the Priority set to high.
Thanks. I'll try that.
how do you turn it off?
Is it in your bios? (I have the Asus P4P800)
Old 01-02-04, 10:09 PM
  #12  
DVD Talk Hero
Thread Starter
 
Join Date: Apr 1999
Location: Duluth, GA, USA
Posts: 37,782
Likes: 0
Received 0 Likes on 0 Posts
Okay, using v.2.59 (which allows for hyperthreading operation), I note that for any encoding done with no filters, it will hog both "threads" at 100% CPU utilization, the Task manager process graph shows both CPU Usage history running at 100%. It's pretty hard to do anything else with the PC.

HT = Hyperthreading
NR = Noise Reduction

If I use the Noise Reduction filter (Level 1), then the load on either CPU thread varies, and the CPU usage varies as TMPGEnc does some crunching for the NR filter, and it takes around 5 times longer than without any filters. I can do some other PC tasks (surf the web, etc) while the NR filter is being used to encode.

The fastest mode of encoding is CBR, Normal mode (just slightly more than the running time of the video file), with the hyperthreading mode enabled.

If I disable HT, then it takes about 10%-30% longer to encode the video file depending on other factors. Only one of the CPU thread shows a lot of activity while the other thread shows minimal activity. Task Manager shows 50% CPU usage.

Some quick-n-dirty stats:

Time (in seconds) to encode a 85 second video segment (Motion Search Precision = Normal) and no filtering:

HT enabled
CBR: 90
2-pass VBR: 179

HT disabled
CBR: 110
2-pass VBR: 207

---------

Time to encode same 85 second video segment (Motion Search Precision = Normal) and Noise Reduction filtering:

HT enabled
CBR: 430
2-pass VBRT: 850

HT disabled
CBR: 440
2-pass VBR: 940

--------

Conclusion (but hardly the last word): Hyperthreading helps if you encode without CPU intensive filtering, like Noise Reduction, but it's only around 15%-25% faster.

With NR filtering, the benefits of HT are less, around 3%-11% faster.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread

Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.