Tech Talk Discuss PC Hardware, Software, Internet and Other Technology

Xserver won't start in Mandrake

Old 05-22-03, 08:10 AM
  #1  
DVD Talk Ultimate Edition
Thread Starter
 
Join Date: Aug 2000
Location: Canada
Posts: 4,538
Xserver won't start in Mandrake

I formatted my second pc again to try and install Mandrake 9.1. As I cannot install from CD, I took the iso file and extracted everything to the second hard drive to do the installation. It does view the files and everything works perfectly until I get to the package installs.

I would say that around 25-35% of my packages give an error message and will not install. My KDE/Gnome packages also give these errors so that could be why it happens, but I'm not sure. I've never figured out why the hell this happens, but it's been doing this for every install in a long time. Notice though that I only downloaded the first 2 cds of 3, but should cd1 normally not be enough to get it up and running?

I'm also experiencing a problem that Logitech OEM mice hardly ever work on this thing so that I can only use the keyboard until I change the mouse (which does not have any up/down movement, only left/right).

After everything is setup, I can boot to Mandrake without any problems, but I can't get the X server started, it gives me the shell and allows me to login, but if I try to start X, it gives an error message and will not open. I will get the message after work as my pc is not here, I'm just posting in case someone has suggestions.

Any ideas why this happens? It always used to work in the past, but now I've done 3 unsuccessfull installs in a row. Another thing to point out is that this started around 4 months ago (the last time I used it) AFTER it had been working correctly for a few months on 9.0. I was able to install RedHat and have it work after that, but I prefer Mandrake. I assumed I had just corrupted my installation and didn't think much of it, but now I reinstall and it happens constantly.
Feneant is offline  
Old 05-22-03, 09:26 AM
  #2  
DVD Talk Special Edition
 
Join Date: Jul 2000
Location: Seattle, WA
Posts: 1,452
Check your Xfree86 log in /var/log. It should give a lot of insight into why Xserver isn't starting.
pantala is offline  
Old 05-22-03, 10:05 AM
  #3  
DVD Talk Ultimate Edition
Thread Starter
 
Join Date: Aug 2000
Location: Canada
Posts: 4,538
The error message says :

/etc/X11/X: Error while loading shared libraries: libz.so.1: cannot open shared object file: No such file or directory
giving up.
xinit: No such file of directory (errno 2): unable to connect to X server
xinit: No such process (errno 3) : Server error.


There is no Xfree86 file that I can see under the log directory.

Im starting to think that the problem is related to the large amount of packages not installing correctly.

Can someone tell me how to install KDE again when logged on to Mandrake?

Last edited by Feneant; 05-22-03 at 03:52 PM.
Feneant is offline  
Old 05-22-03, 10:36 PM
  #4  
DVD Talk Ruler
 
General Zod's Avatar
 
Join Date: Sep 2001
Location: Santa Clarita, CA
Posts: 21,280
Never seen this behavior on install and i've installed Linux a whole buncha times. Sounds like it isn't installing xwindows completely, and then it is erroring out trying to use the libraries that would normally come with it.

I know you might not like this suggestion but... use Redhat
General Zod is offline  
Old 05-23-03, 04:07 AM
  #5  
DVD Talk Special Edition
 
Join Date: Jul 2000
Location: Seattle, WA
Posts: 1,452
With that many packages failing, it's just going to be a cascade of errors, with multiple problems showing up for each one problem you may fix.

Some options now include:
Install off CRC verified CD media (but in your first post you say this is not an option), or
Network install, or
Install Redhat. RH9 has the smoothest, easiest, and fastest linux install I've seen so far.

You can try to fix your xwindows install, but I get the feeling it won't be any prettier once the other problems come up.

Last edited by pantala; 05-23-03 at 04:10 AM.
pantala is offline  
Old 05-23-03, 05:11 AM
  #6  
DVD Talk Hero
 
jfoobar's Avatar
 
Join Date: Jun 2000
Posts: 37,659
The only time I have had X fail to install/start was when I was trying to use an unsupported video card with FreeBSD.

Mandrake traditionally has a very good installer also, so jumping ship to RedHat doesn't seem like much of a solution (especially when you could jump ship to Gentoo instead ).

I would suggest you post your problems on a Mandrake board or maybe linuxquestions.org.
jfoobar is offline  
Old 05-23-03, 06:36 AM
  #7  
DVD Talk Ultimate Edition
Thread Starter
 
Join Date: Aug 2000
Location: Canada
Posts: 4,538
Might be ill post to Mandrakes user assistance place...

if not, I'll try Redhat, I think I have 9.0 lying around...
Feneant is offline  
Old 05-23-03, 04:38 PM
  #8  
DVD Talk Special Edition
 
Join Date: Jul 2000
Location: WashingtonDC
Posts: 1,182
mandrake is pretty idiot-proof (ie, even i can use it), but it sounds like you must have some hardware that just isn't supported yet? (is this old hardware or new stuff?) i'd eitehr post on a mandrake board (http://www.mandrakeusers.org was really helpful to me) or google to see if someone else has issues with the same hardware.

i'd love to try gentoo but i had trouble getting my network card to work after the initial install... so i couldn't emerge anything. one of these days i'll try again when i'm a bit more adept and have lots of time to recompile repeatedly.
Eeyore is offline  
Old 05-23-03, 05:28 PM
  #9  
lxl
Senior Member
 
Join Date: Jun 1999
Location: San Jose, CA
Posts: 813
Originally posted by Feneant
The error message says :

/etc/X11/X: Error while loading shared libraries: libz.so.1: cannot open shared object file: No such file or directory
giving up.
This file should be installed by zlib/zlib-devel package.
lxl is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread

Archive Advertising Cookie Policy Privacy Statement Terms of Service

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.