Go Back  DVD Talk Forum > General Discussions > Tech Talk
Reload this Page >

sharing option missing ...

Tech Talk Discuss PC Hardware, Software, Internet and Other Technology

sharing option missing ...

Old 09-27-01, 01:52 PM
  #1  
Stealth Moderator
Thread Starter
 
namja's Avatar
 
Join Date: Oct 1999
Location: In Transit, HQ
Posts: 25,006
Received 2 Likes on 2 Posts
sharing option missing ...

I'm trying to share the C: drive on my notebook computer with other computers in my network. I right clicked on the C: drive and ... there is no Sharing option. I'm using Windows 2000 and I'm logged in as the Administrator.

There are 2 desktops computers in the network (total of 3 computers in the network). I set up the Sharing correctly on those 2 computers so that they can now see each other. In fact, my notebook computer can see the 2 desktop computers (and all the computers can successfully ping one another), so it's not a connection problem.

As I mentioned up top, I'm logged in as the Administrator. The File and Printer Sharing for Microsoft Networks is checked. What am I missing here?
Old 09-27-01, 02:04 PM
  #2  
X
Administrator
 
X's Avatar
 
Join Date: Oct 1987
Location: AA-
Posts: 10,763
Likes: 0
Received 4 Likes on 3 Posts
Have you gone into Administrative Tools -> Computer Management -> Disk Management and checked out the sharing tab on your disk's properties?
Old 09-27-01, 02:22 PM
  #3  
Stealth Moderator
Thread Starter
 
namja's Avatar
 
Join Date: Oct 1999
Location: In Transit, HQ
Posts: 25,006
Received 2 Likes on 2 Posts
Originally posted by X
Have you gone into Administrative Tools -> Computer Management -> Disk Management and checked out the sharing tab on your disk's properties?
There is no sharing tab on the notebook. There is one on the desktop and it's enabled. Both are on Windows 2000 ...
Old 09-27-01, 02:51 PM
  #4  
X
Administrator
 
X's Avatar
 
Join Date: Oct 1987
Location: AA-
Posts: 10,763
Likes: 0
Received 4 Likes on 3 Posts
How about uninstalling and then reinstalling the File and Printer Sharing in your Local Area Connection? You do belong to the same workgroup/domain as your other computers, don't you? Same password on the Administrator account?
Old 10-01-01, 03:30 AM
  #5  
Stealth Moderator
Thread Starter
 
namja's Avatar
 
Join Date: Oct 1999
Location: In Transit, HQ
Posts: 25,006
Received 2 Likes on 2 Posts
still NOT working

Here's more info on the setup:

Computer A: desktop running Windows2000. Logged in as Administrator and password is ABC. The computer name is namja.

Computer B: notebook running Windows2000. Logged in as Administrator and password is ABC. The computer name is namja2.

Computer C: desktop running Windows98. Logged in as namja3 and there is no password. The computer name is namja3.

All three computers use the name Workgroup as the workgroup. They are all connected to a router which is connected to a cable modem. I am using TCP/IP only.

Computer A sees: A & C on the network and has full access to A & C.
Comptuer B sees: A & C on the network and has full access to A & C.
Computer C sees: A & C on the network but has no access to A.

I set up Sharing on computers A & C. On computer B, there is no Sharing option when I right click on the drives. I haven't touched any of the Users settings.

What else do I need to do?
Old 10-01-01, 03:53 AM
  #6  
X
Administrator
 
X's Avatar
 
Join Date: Oct 1987
Location: AA-
Posts: 10,763
Likes: 0
Received 4 Likes on 3 Posts
I would seriously consider removing (uninstalling) all the networking from the computer without the sharing and then reinstalling it. You could always try to map the Adminstrative share of \\NotebookName\C$ on machine A, just for fun. But if it's not there, you don't have any sharing. Try the reinstall under the computer name's Administrator account.
Old 10-01-01, 04:13 AM
  #7  
Stealth Moderator
Thread Starter
 
namja's Avatar
 
Join Date: Oct 1999
Location: In Transit, HQ
Posts: 25,006
Received 2 Likes on 2 Posts
Originally posted by X
I would seriously consider removing (uninstalling) all the networking from the computer without the sharing and then reinstalling it. You could always try to map the Adminstrative share of \\NotebookName\C$ on machine A, just for fun. But if it's not there, you don't have any sharing. Try the reinstall under the computer name's Administrator account.
I tried this the first time you posted this. Nothing. Mapping doesn't work as it gives me a not found error.

I really think that I need to do something to the notebook computer since it's not even allowing me the Sharing option when the Sharing is enabled in the Network properties. I dunno ...

Also, do I need to set up Computer A to give Computer C permission to access Computer A? From Computer C, if I double click on Computer A, it says that it has no permission or something like that.
Old 10-01-01, 04:32 AM
  #8  
X
Administrator
 
X's Avatar
 
Join Date: Oct 1987
Location: AA-
Posts: 10,763
Likes: 0
Received 4 Likes on 3 Posts
You haven't turned off any services like Server on the notebook, have you? Check to see if Server has started in Services.

You have the Client for Microsoft Networks showing up in your Networking properties too, don't you?

I'm not positive about this, but you can add the user that you're logged in with on C to the A machine's users and set the appropriate permissions. (I don't work with workgroups much.)

Or you can map to a drive share in Explorer like \\namja\WhateverTheDriveIsSharedAs or \\namja\C$. It will ask for a login at that point and you can use the A Administrator's login.
Old 10-01-01, 04:43 AM
  #9  
Stealth Moderator
Thread Starter
 
namja's Avatar
 
Join Date: Oct 1999
Location: In Transit, HQ
Posts: 25,006
Received 2 Likes on 2 Posts
Originally posted by X
You haven't turned off any services like Server on the notebook, have you? Check to see if Server has started in Services.
checking now.
You have the Client for Microsoft Networks showing up in your Networking properties too, don't you?
yes.
I'm not positive about this, but you can add the user that you're logged in with on C to the A machine's users and set the appropriate permissions. (I don't work with workgroups much.)
i tried that to no avail.
Or you can map to a drive share in Explorer like \\namja\WhateverTheDriveIsSharedAs or \\namja\C$. It will ask for a login at that point and you can use the A Administrator's login.
i mapped it in computer C. when i try to enter, it asks for only the password, not a username. and the password for the Administrator or for the name for computer C doesn't work.
Old 10-01-01, 04:46 AM
  #10  
X
Administrator
 
X's Avatar
 
Join Date: Oct 1987
Location: AA-
Posts: 10,763
Likes: 0
Received 4 Likes on 3 Posts
Originally posted by namja
i mapped it in computer C. when i try to enter, it asks for only the password, not a username. and the password for the Administrator or for the name for computer C doesn't work.
Looks like you're going to have to login to C with username of "Administrator".
Old 10-01-01, 04:50 AM
  #11  
Stealth Moderator
Thread Starter
 
namja's Avatar
 
Join Date: Oct 1999
Location: In Transit, HQ
Posts: 25,006
Received 2 Likes on 2 Posts
Originally posted by X
Looks like you're going to have to login to C with username of "Administrator".
First, now computers A & B work perfectly. They can access all the computers. I uninstalled then reinstalled the "File and Printer Sharing for Microsoft Networks" like you mentioned for the 3rd time, and this time it worked.

Thanks.

Now, Computer C is still not cooperating. Maybe I'll make the username for Computer C to be Administrator. I'm tired of trying now so I'm not going to work on that until tomorrow.
Old 10-01-01, 09:23 PM
  #12  
Stealth Moderator
Thread Starter
 
namja's Avatar
 
Join Date: Oct 1999
Location: In Transit, HQ
Posts: 25,006
Received 2 Likes on 2 Posts
Originally posted by X
Looks like you're going to have to login to C with username of "Administrator".
Thanks X. I changed it to Administrator (and also made the PW the same on all 3 ... is this necessary?) and now everything's working. Now all 3 share one printer and one cable modem.
Old 10-01-01, 09:27 PM
  #13  
X
Administrator
 
X's Avatar
 
Join Date: Oct 1987
Location: AA-
Posts: 10,763
Likes: 0
Received 4 Likes on 3 Posts
Originally posted by namja

Thanks X. I changed it to Administrator (and also made the PW the same on all 3 ... is this necessary?
Don't know for sure in a workgroup, probably different PW's are ok. But you could try it and let me know.
Old 10-18-01, 03:28 AM
  #14  
Video Gamer Reviewers
 
Join Date: May 2000
Posts: 4,162
Likes: 0
Received 0 Likes on 0 Posts
I don't know if this helps, but somewhat of an explanition to how the permissions work...

When a computer that is running Windows 98 has a shared device, and another computer attempts to utilize it, it requires only a password. A computer running Windows 2000 Professional (or Server that is not domain controller on a domain) shares a device, it requires a user account and password.

when a Windows 98 computer accesses a share on a Windows 98 computer it will store the password (or not store it) for each specific share.

When the Win2k computer accesses the Win98 computer, it will only submit the password of the account. For a Win2k computer to access a Win 98 computer, the password of the Win2k account must be the same password as the shared device on the Win 98 computer.

When a Win 98 computer accesses a Win2k computer, it requires permissions to access the share. First it will check the account and password, if it fails, it of course denies access. To enable a Win98 computer to access a Win2k computer,
an account must exist on the Win2k that is the account on the Win98 computer,
and also there must be permission to access that shared device for that account.

hope this helped some what, or at least was interesting...
Old 10-18-01, 04:50 AM
  #15  
Stealth Moderator
Thread Starter
 
namja's Avatar
 
Join Date: Oct 1999
Location: In Transit, HQ
Posts: 25,006
Received 2 Likes on 2 Posts
Originally posted by jrobinson
I don't know if this helps, but somewhat of an explanition to how the permissions work...

When a computer that is running Windows 98 has a shared device, and another computer attempts to utilize it, it requires only a password. A computer running Windows 2000 Professional (or Server that is not domain controller on a domain) shares a device, it requires a user account and password.

when a Windows 98 computer accesses a share on a Windows 98 computer it will store the password (or not store it) for each specific share.

When the Win2k computer accesses the Win98 computer, it will only submit the password of the account. For a Win2k computer to access a Win 98 computer, the password of the Win2k account must be the same password as the shared device on the Win 98 computer.

When a Win 98 computer accesses a Win2k computer, it requires permissions to access the share. First it will check the account and password, if it fails, it of course denies access. To enable a Win98 computer to access a Win2k computer,
an account must exist on the Win2k that is the account on the Win98 computer,
and also there must be permission to access that shared device for that account.

hope this helped some what, or at least was interesting...
Hey, that helps a LOT. Maybe tomorrow, I'll play with the username/pw settings on the three computers.


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread

Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.