DVD & Home Theater Gear Discuss DVD and Home Theater Equipment.

Need some help, please - Toshiba 62"

Old 04-30-15, 05:36 PM
  #1  
Needs to Contact Admin about multiple accounts
Thread Starter
 
Join Date: Jun 2004
Location: Winston Salem, NC
Posts: 2,806
Need some help, please - Toshiba 62"

OK Guys,

Here's the problem. I have a Toshiba 62HM84 that is now 10 years old.

Over the last month or so I have noticed a strange sound, almost like a crackling sound that seems to be coming from the area that houses the lamp.

Last week when I turned it on, I got no picture or sound. But the red and green power lights blinked on and off and then the TV turned off, but then cycled back on. It did this probably 6 or 7 times before stopping.

Now I've had this problem before about 3 or 4 years ago and it turns out it was the lamp that deed replacing.

I picked up a new lamp from eBay and installed that but seem to be having the same problem, so therefore I'm not sure if it was the lamp before or whether it is different problem.

From what I've also read it could possibly be also the ballast that needs replacing. Does this sound it's making be something along those lines?

Has anyone dealt with a problem similar to this? If so, what was the outcome?
DVDMagic is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread

Archive Advertising Cookie Policy Privacy Statement Terms of Service

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.