DVD Talk
My Compaq only displays the red COMPAQ screen (forever) [Archive] - DVD Talk Forum


View Full Version : My Compaq only displays the red COMPAQ screen (forever)

03-20-06, 07:08 PM
This is sort of part two of this thread:


I finally got my computer pared down to just keyboard, mouse and monitor. I dusted out all the giant dust bunnies and silt, cleaned up and organized and was ready to commence Operation Save old Computer (itís not really that old).

So, Iím hitting F10 at the COMPAQ screen to get to BIOS and the COMPAQ logo just stays. I reboot a couple of times and the computer starts making a weird buzzing noise (inside the cabinet). I turn it off for a while, grab a fire extinguisher and try again. No buzzing noise this time. Iím patientÖsort of hanging around about 10 minutes and suddenly my monitor loudly pops and goes dead. The monitor is a fairly new Viewsonic. Anyway, that scared the shit out of me and fire extinguisher in hand I turn the monitor back on. Itís OK.

So now my main problem is that when I turn on the computer it never goes past the screen that has the big, red COMPAQ logo with a blinking cursor in the upper right hand corner. I can't get to safe mode, BIOS or even any other blank or otherwise display.

I've tried it with the XP disc in and out of the drawer.

Is it time for the sledgehammer or has anyone had this happen and fixed it?

03-21-06, 06:12 PM
bumping because I can only get on-line at work

Does this symptom mean that my processor is shot for good?

03-22-06, 01:02 AM
You can try removing the CMOS battery (located on the motherboard) for 30 min to an hour. Then put it back in and try again.

It isn't completing posting from the looks of it and is getting hung up on something. Make sure nothing is loose: cables, cards, memory, cpu, etc.

03-22-06, 03:56 PM
Thanks Nefarious.

That never even occurred to me. I may have to replace it. Do you have to manually reset the time, date and disc configs?

I'll see how this goes tonight. :)

03-22-06, 04:50 PM
I had the same issue with an older Compaq Deskpro at the office. Turned out to be a bad CD drive that was causing it to hang. I pulled the CD's IDE cable from the board and it booted up fine after that. Try giving that a shot if the CMOS battery doesn't work.

03-22-06, 05:55 PM

03-22-06, 08:24 PM
It should auto-configure w/ the exception of maybe time & date.

03-23-06, 01:24 PM
WellÖIt worked. I switched out the CMOS for about an hour and booted up. The computer read its RAM and then gave me grief. I remembered matomeís suggestion about the CD drives and realized that my R/W drive was busted so I unplugged it.

That got me into BIOS and I set the time and date and rearranged the drive boot order.
It still gives me an error message about ten minutes into loading the OS disc (XP Home Ed.) so I havenít been able to actually get up and running, but at least Iím past that damn COMPAQ screen and have the option to at least fiddle with the guts of the software.

Would it be advisable to invest in a new CMOS battery or do they work like car batteries? I kept the machine running all night in case it was rechargeable.

Thanks for the great advice youse guys! :)

Content Relevant URLs by vBSEO 3.2.0