Release List Reviews Shop Join News DVD Giveaways Video Games Advertise
DVD Reviews | Theatrical Reviews | Adult DVD Reviews | Video Game Reviews | Price Search Buy Stuff Here
DVD Talk
DVD Reviews DVD Talk Headlines HD Reviews


Add to My Yahoo! - RSS 2.0 - RSS 2.0 - DVD Talk Podcast RSS -


Go Back   DVD Talk Forum > General Discussions > Tech Talk

Tech Talk Discuss PC Hardware, Software, Internet and Other Technology

Reply
 
Thread Tools
Old 02-06-02, 01:55 PM   #1
palebluedot
DVD Talk Ultimate Edition
 
Join Date: Jan 2001
Location: Seattle
Posts: 4,452
Okay...I got a stumper for you. (Regards lock-out on changing wallpaper)

I am running windows 2000 at work. My company has locked us out from changing our wallpaper. If I right click on the desktop and click properties and go to the background tab I can't select a different background and the scroll bar for the backgrounds is disabled.

I have scoured the registry for the DWORDs "NoChangingWallpaper" and "NoDisplayBackground" (which are usually added in to do this) however I can't find those entries. So I am not sure it is a registry hack they are using to prevent changing the wallpaper.

Any ideas on this one?
  Reply With Quote
Old 02-06-02, 02:11 PM   #2
Aghama
DVD Talk Limited Edition
 
Join Date: Oct 1999
Location: A suburbē of Miami
Posts: 5,944
Try changing the "Wallpaper" key in:

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\General
  Reply With Quote
Old 02-06-02, 02:34 PM   #3
palebluedot
DVD Talk Ultimate Edition
 
Join Date: Jan 2001
Location: Seattle
Posts: 4,452
Quote:
Originally posted by Aghama
Try changing the "Wallpaper" key in:

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\General
Well the key for that entry is %systemroot%background.bmp

I'm not what changing that would do for me. Also that has nothing to do with not being able to choose a image file from the desktop properties menu or even use the scroll bar. I think that is the key to this whole problem.

Thanks for your suggestion though.
  Reply With Quote
Old 02-06-02, 02:47 PM   #4
Aghama
DVD Talk Limited Edition
 
Join Date: Oct 1999
Location: A suburbē of Miami
Posts: 5,944
Quote:
Originally posted by palebluedot

Well the key for that entry is %systemroot%background.bmp
Right, try either changing that to the file you're trying to make your background (.jpg's work), or put your background in that directory in place of background.bmp. A workaround if you will.
  Reply With Quote
Old 02-06-02, 03:09 PM   #5
palebluedot
DVD Talk Ultimate Edition
 
Join Date: Jan 2001
Location: Seattle
Posts: 4,452
Quote:
Originally posted by Aghama

Right, try either changing that to the file you're trying to make your background (.jpg's work), or put your background in that directory in place of background.bmp. A workaround if you will.
Okay I changed it and I was able to load my background image. However after loging off and back on it reverted back to the forced background.

I went into the registry and edited every single entry associated with background and wallpaper and pointed to the file I wanted.

I logged off and on again and it reverted back. Whatever it is, it is deep. Hmmmm.

Also I have overwritten the forced file with my own(changed the name of mine to the forced file). I have made it read only, hidden and I have shut off permissions for it, yet it still gets overwritten when I log back on.

Last edited by palebluedot; 02-06-02 at 03:14 PM.
  Reply With Quote
Old 02-06-02, 03:33 PM   #6
Dead
Mod Emeritus
 
Join Date: Feb 1999
Location: Gone to the islands - 'til we meet again.
Posts: 19,053
Quote:
Originally posted by palebluedot


Okay I changed it and I was able to load my background image. However after loging off and back on it reverted back to the forced background.

I went into the registry and edited every single entry associated with background and wallpaper and pointed to the file I wanted.

I logged off and on again and it reverted back. Whatever it is, it is deep. Hmmmm.

Also I have overwritten the forced file with my own(changed the name of mine to the forced file). I have made it read only, hidden and I have shut off permissions for it, yet it still gets overwritten when I log back on.

Sounds like they are using Win2000 Domain Policies to control the settings. That would explain them going back every time you log on the system.
__________________
Breathe In,
Breathe Out,
Move On.
  Reply With Quote
Old 02-06-02, 03:51 PM   #7
Numanoid
DVD Talk Hero
 
Numanoid's Avatar
 
Join Date: Aug 2000
Location: Down in 'The Park'
Posts: 27,548
Sounds like they're using a System Policy (which lets them control what you can and cannot alter). The policy is usually stored on a server and loads onto the workstation at each login. Try using Internet Explorer to change the wallpaper (open the pic in IE, then right-click and choose "Set as Background"). This sometimes bypasses the policy.
__________________
everything Numanoid has said is true - Talkin2Phil
  Reply With Quote
Old 02-06-02, 04:33 PM   #8
palebluedot
DVD Talk Ultimate Edition
 
Join Date: Jan 2001
Location: Seattle
Posts: 4,452
Quote:
Originally posted by Numanoid
Sounds like they're using a System Policy (which lets them control what you can and cannot alter). The policy is usually stored on a server and loads onto the workstation at each login. Try using Internet Explorer to change the wallpaper (open the pic in IE, then right-click and choose "Set as Background"). This sometimes bypasses the policy.
Yeah...if I right click on a picture in internet explorer and do set as wallpaper it doesn't work.

It must be a system policy. Anyway around that?
  Reply With Quote
Old 02-06-02, 08:51 PM   #9
Aghama
DVD Talk Limited Edition
 
Join Date: Oct 1999
Location: A suburbē of Miami
Posts: 5,944
Quick & Dirty fix: stick a batch file in your startup dir.
  Reply With Quote
Old 02-06-02, 10:03 PM   #10
zuffy
DVD Talk Legend
 
Join Date: Jan 2000
Location: Region 1
Posts: 16,200
Quote:
Originally posted by palebluedot


Yeah...if I right click on a picture in internet explorer and do set as wallpaper it doesn't work.

It must be a system policy. Anyway around that?
Get domain admin rights and remove the policy or be best friend with one of the admin
  Reply With Quote
Old 02-06-02, 10:07 PM   #11
zuffy
DVD Talk Legend
 
Join Date: Jan 2000
Location: Region 1
Posts: 16,200
I don't know if this will help or not since, if I remember correctly, domain policy over-rides local policy.
Run gpedit.msc from the the Run...
goto -->User Configuration --> Administrative Templates --> Desktop --> Prevent Changing Wallpaper --> Disabled
  Reply With Quote
Old 02-08-02, 10:39 AM   #12
palebluedot
DVD Talk Ultimate Edition
 
Join Date: Jan 2001
Location: Seattle
Posts: 4,452
They are using a group policy to do this...oh well. Thanks for the responses.
  Reply With Quote
Old 02-08-02, 12:24 PM   #13
Neitzl
DVD Talk Gold Edition
 
Join Date: Aug 1999
Location: Chicago, IL
Posts: 2,334
yup, local policy is overridden, it's one of the bottom level policies. I love group policies, where I work, I set it so that you can't even right click and get the context menu. There are tons more settings that I put into place that most everyone hates what I do, but I tell them to try and go around the security, and when they do, I'm sure I'll be able to fix it.
Group Policy and Fortress, hand in hand, work so well.

Neitzl
__________________
DVDs

Comics
  Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


All times are GMT -5. The time now is 12:38 AM.

Rules - DVD Talk - Archive - Privacy Statement - Top

Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.2.0
Copyright 2011 DVDTalk.com All Rights Reserved. Privacy Policy and Terms of Use.