DVD Talk
HELP! DVD player/video mode blue screen ONLY! [Archive] - DVD Talk Forum
 
Best Sellers
1.
2.
3.
4.
5.
6.
7.
8.
The Longest Day
Buy: $54.99 $24.99
9.
10.
DVD Blowouts
1.
2.
3.
4.
5.
6.
7.
Alien [Blu-ray]
Buy: $19.99 $9.99
8.
9.
10.

PDA
DVD Reviews

View Full Version : HELP! DVD player/video mode blue screen ONLY!


calhoun07
07-26-05, 07:56 PM
I was watching a DVD (Dr. Who Season One Vol 2) on my Malata DVP-520 and I was trying to access the subtitle button, but suddenly the screen went blue and the green word VIDEO just appears on my TV. I've tried turning everything off, both the TV and DVD player and turning it all back on again, but still the same problem. I can hear the DVD content playing, I just cannot see it. I am figuring either something got hit by accident on my DVD remote or my TV remote but I have no idea how to fix it. Help please!

HN
07-26-05, 08:03 PM
sounds like you switched your video input - you know video 1 for rca, video 2 for svideo, video 3 for component, etc.

is your remote a universal? the subtitle button in dvd player mode might be the video switch button in tv mode.

or you just sat on the tv remote at the same time you pressed the subtitle button ;)

calhoun07
07-26-05, 08:08 PM
sounds like you switched your video input - you know video 1 for rca, video 2 for svideo, video 3 for component, etc.

is your remote a universal? the subtitle button in dvd player mode might be the video switch button in tv mode.

or you just sat on the tv remote at the same time you pressed the subtitle button ;)

The remotes for both the DVD player and TV are specific to those modles and not universal.

How can I set the video input on the DVD player? When I click on the set up menu, all I see is that blue screen and the green VIDEO in the corner.

HN
07-26-05, 08:28 PM
ah, then my guess is the dvd remote is innocent. something was pressed on the tv remote. find a "source" button or "video" button on your tv itself or tv's remote.

can't find it? take a pic of the remote(s) and we'll have a look :D

calhoun07
07-26-05, 08:30 PM
ah, then my guess is the dvd remote is innocent. something was pressed on the tv remote. find a "source" button or "video" button on your tv itself or tv's remote.

can't find it? take a pic of the remote(s) and we'll have a look :D

I have to select the video button to watch my DVD. I know exactly where the button is, but I am not sure what the next step would be.

HN
07-26-05, 08:37 PM
cycle thru the video sources via the tv remote.
(i think you'd have to go into the dvd player's menu in order to change the video output so i ruled that out; unless the dvd player remote has a button specifically for that in which case, try on that)

calhoun07
07-26-05, 08:45 PM
cycle thru the video sources via the tv remote.
(i think you'd have to go into the dvd player's menu in order to change the video output so i ruled that out; unless the dvd player remote has a button specifically for that in which case, try on that)


I don't believe my TV remote has that capability. All the "Video Mode" button does is switch it from regular TV to where I can watch my DVD. The other buttons on there include "reset" which resets my saved channels, caption, sleep, menu (which only allows me to select movie, news, sports, or manual for the picture selections), recall, mute, and display.

HN
07-26-05, 08:48 PM
what tv do you have?
(gonna hit the road. will pick this up where we left off if still not resolved)

calhoun07
07-26-05, 08:55 PM
what tv do you have?
(gonna hit the road. will pick this up where we left off if still not resolved)

Sanyo

calhoun07
07-26-05, 09:08 PM
I honestly believe something happened with the DVD player and the settings. It's like when you select "progressive scan", which is the same problem other people here have experienced. For grins and giggles, does anybody know how to get the Malata 520 back to factory specs?

calhoun07
07-26-05, 09:14 PM
I found this search in Google (which brought me back to this forum!):

Phalex
12-23-03, 11:12 PM
I just got a new TV that features component in, and 720p/1080i etc. However, when I first hooked up my Malata DVP-520, the colors were of course, way off since it was still using its previous video output configuration. So, I went to the setup menu, and scrolled through the different video output modes, until the 3rd one, when my screen went black. The DVD I had in was still playing, and I'm at a total loss since I can't see the menu to actually change it back to the way it was. So if anyone has this player, and knows of a way to reset it to factory defaults, OR if you can tell me the number of times to press the arrow keys (i.e. 6 down, 2 right, enter, or whatever) I would be in your debt. Thank you!
Phalex
12-23-03, 11:30 PM
Ok, figured it out, sorry (hold Clear for 5 seconds)


That worked for me. It wasn't my TV remote after all. I have no idea how the hell it happened, as I was just trying to select the audio and subtitle selections for the region 2 Dr. Who DVD. Maybe it's a glitch on the Dr. Who DVD??? Never had this problem before when trying to access those features.

Thanks SOOOO much to HN for trying to help!

HN
07-26-05, 10:01 PM
:lol: i think all i did was get your mind jogging. glad you got it back to normal :thumbsup:

calhoun07
07-26-05, 10:38 PM
Well, I know you didn't answer my question but at least you put forth an effort and showed an interest, and that is appreciated!

renaldow
07-27-05, 02:44 AM
I just saw all of this now, and I'm glad it worked out. That kind of thing sucks, and you don't really appreciate a player with features like having all outputs always being on or autosensing whether PS is accepted by the TV or not until something like this happens!